EasyBCD win7 unbuntu 10.10

#1
Hi, I have everything installed following this guide. I read ahead and planned for this.

http://www.linuxbsdos.com/2010/11/04/how-to-dual-boot-ubuntu-10-10-and-windows-7/

I paid attention to this part in paticular.
Note: It has been reported that Windows 7 tends to mess with the GRUB menu after a Windows update/upgrade. To avoid any issue that might arise from that, you need to install GRUB to the boot partition of the Ubuntu installation, then use EasyBCD to edit the Windows boot menu and add an entry for Ubuntu. This method was used in how to dual-boot Fedora 14 and Windows 7.

So I followed these instructions
and installed GRUB in my /dev/sda2 which I made my /boot partition.

The next step relevant to this tutorial is the boot loader configuration step. The boot loader used by Fedora 14 is GRUB Legacy. By default, it is installed in the Master Boot Record (MBR). What we want to do here is install it some place else, and the best alternative location to install GRUB, the GRand Unified Bootloader, is in the /boot partition (/dev/sda3) of the Fedora installation. The reason behind this choice of location is this: If it is installed in the usual location, Windows will likely overwrite parts of it the next time you upgrade/update Windows.
Following the directions in that link for EasyBCD knowing that Ubuntu 10.10 uses GRUB 2 and not legacy thinking it would still work the same.
When I substitue GRUB 2 in place of GRUB (legacy) in the type box then the "device" button isn't clickable to direct it to where I have GRUB installed to add it.

When in the Add New Entry tab, click on the Linux tab as shown. The two entries that we need to tweak here are in the Type and Device dropdown menus. Since Fedora 14 uses GRUB Legacy as the boot loader, select that in the Type menu. Then select the partition you installed GRUB into from the Device menu. In this example, GRUB (Legacy) was installed on the third primary partition, /dev/sda3, which is the /boot partition of the Fedora installation. With those completed, click on Add Entry, then on the Edit Menu tab to see what the new Windows boot menu looks like.
What am I doing wrong or is not possible? If not possible they need to change the directions.

At first I let GRUB handle the booting and it worked a couple time then it wouldn't and had to do the repair for windows. So then I redid everything and trying this way that I can't get to work either.

Thanks
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
EasyBCD will locate grub2 for you. That's why the option disappears.
Just select grub2 from the dropdown.
Make sure you're using the very latest Beta
 
#5
kbz1960,

One problem is that you’re using a guide for dual booting Windows 7 and Ubuntu that has nothing to do with Easy BCD boot loader. I believe the specific problem you are having relates to the fact that you set up the mount point incorrectly. You should simply assign “ / “ for the mount point. Not a “ /boot “. You want to install GRUB-2 TO “ /dev/sda “. That will put the GRUB-2 into the MBR which is where you want it.

So after you install Windows 7 and then Ubuntu 10.10 you will have a boot loader screen coming from GRUB-2 with an option to boot into Windows 7. Use that boot option to get into Windows 7. Once in Windows 7 install Easy BCD. Open Easy ECD click on “add new entry”. Click on the Linux/BCD tab. Under type select GRUB-2. Click on add entry.

Now reboot. Now you should see the boot loader menu you saw before coming from GRUB-2. Click on the Windows 7 entry. Now you will see the boot loader screen coming from Easy BCD. Click on the Ubuntu entry. Now you should be back to the GRUB-2 boot loader screen. Now we know everything is working we want to make the Easy BCD boot loader the primary boot loader. Boot back into Windows 7.

Start Easy BCD. Under boot loader setup click on write MBR. Under BCD back a repair select the radio button for re-create/repair boot files. Click on perform action. Later on if you want you can edit the grub file to set the timeout time to zero so you won’t see the GRUB-2 boot menu anymore.