easybcd with windows 7 and 8 help.

Hi, I have windows 7 installed and also wanted to try windows 8 preview, i installed easybcd on windows 7 and have both entries in boot with 7 being default. When rebooting and trying to get into windows 8 i get an error of winload not found.How can I fix this. My windows 7 was installed first a while back.
Windows bootmgr, whilst ostensibly the same module with the same function in Vista, 7 and 8, is actually a new release with a new digital signature in each newer OS. The older release is not forward compatible, so sees the digital sig of the newer as invalid.
The newer is backward compatible, so is quite happy with the older sigs.
A workaround is to install W8 in such a way that it does not see W7 (and therefore leaves the W7 boot files untouched), change the BIOS to boot from W8 and add a W7 entry to the W8 menu.
You're quite right, the BIOS isn't involved if you're talking about 2 partitions on the same HDD.
That surprises me though because normally if you install W8 on a HDD where W7 already exists, W8 will take over the boot from W7 and update the boot files on the W7 boot partition, and you should automatically have seen a working dual boot from the W8 boot files.
Did you switch the "active" flag to W8 before installing, and then switch it back afterwards ?
I don't know how otherwise you got a W8 install with W7 still bootable through its own boot files.
thks for reply ,i did not see any active flag but is it fixable that way now? WhAT I did was have the partition ready boot from dvd and choose partition clean install ,and windows 8 did its thing. After reboot I got that winload error.Thks
Can you post a Disk Management screenshot and the EasyBCD "view settings" contents (detailed mode).
The sticky thread will tell you how if you need help.
Thks for reply ,sorry I looked at disk management and the windows 8 is on another hard drive on second partition. Do i still need to send u a screenshot of both items or can we fix it without the scrrenshots?
In that case go back to my first reply and change the BIOS to boot from the W8 HDD.
No problem.
Just set your BIOS back to boot from the W7 HDD when W8 starts to annoy you.