EBCD 2.0.0.90 Grub2 / Ubuntu9.10 does not boot

curryrotweiss

New Member
hi,
first of all: thanks for a great tool!

my problem:
in ebcd beta86-90 chainloading my grub2-bootmenu / ubuntu-9.10-desktop-i386 doesn't work anymore. i reinstalled ebcd2.0.0.82 today to make sure, that the reason is not grub2-related: booting grub2-menu/ubuntu works now!
(first booting into SG2D (SuperGRubDisk) and starting ubuntu from there worked beginning with ebcd2.0.0.86. in older vista/ebcd-installations i had no possibility to add iso-boot-entry. after i downgraded to ebcd2.0.0.82 this morning, my sg2d-bootmenu-entry continues working)

my EBCD config:
1) Vista Enterprise 32bit (sda1)
2) Grub2 / Ubuntu 9.10 Desktop x86 (sda3)
3) Super Grub 2 Disk 1.30 (sgd_cdrom_1.30.iso-file located on sda7, ntfs)
------------------------------------------------------------
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-us
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {e70cd449-3982-11df-a102-005056c00008}
resumeobject {e70cd448-3982-11df-a102-005056c00008}
displayorder {e70cd449-3982-11df-a102-005056c00008}
{e70cd44a-3982-11df-a102-005056c00008}
{c05e9f8b-3668-11df-a1af-005056c00008}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10
resume No

Windows Boot Loader
-------------------
identifier {e70cd449-3982-11df-a102-005056c00008}
device partition=C:
path \Windows\system32\winload.exe
description Ve 32 de
locale en-us
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice partition=C:
systemroot \Windows
resumeobject {e70cd448-3982-11df-a102-005056c00008}
nx OptIn
detecthal Yes

Real-mode Boot Sector
---------------------
identifier {e70cd44a-3982-11df-a102-005056c00008}
device partition=C:
path \NST\AutoNeoGrub1.mbr
description Ubu9.10

Real-mode Boot Sector
---------------------
identifier {c05e9f8b-3668-11df-a1af-005056c00008}
device boot
path \NST\AutoNeoGrub0.mbr
description SG2D (sgd_cdrom_1.30.iso)
------------------------------------------------------------


my hd-layout:

sda1: ntfs, vista, active, easybcd
sda2: ext4, empty/unused
sda3: ext4, ubuntu/grub2 (complete installation, no separate boot)
sda5: linux-swap
sda6: ext4, empty/unused
sda7: ntfs, data (including SG2D-.iso (SuperGrubDisk))


hope, i included the information you would like to see here.
please let me know, if you need any additional information.

thanks a lot for your work!!
 

mqudsi

Mostly Harmless
Staff member
Hi,

Is the above output after installing the Ubuntu entry with Build 82 or 90?
 

curryrotweiss

New Member
Hi,

Is the above output after installing the Ubuntu entry with Build 82 or 90?
hi again,
the bootmenu-entry was created with Build 82.

now i did the following additional steps:
1) reinstall Build 90 / leaving my 3 menu-entries (see above) untouched
2) create additional entry for Ubuntu (within Build 90):
Type: GRUB 2
Name: Ubu9.10_TEST_ebcd2.0.0.90
(i double checked, that i chose the option "Type: GRUB 2")
below you can see the resulting output for the new entry (overview/detailed):
------------------------------------------------------------
overview:

.......
.......

Entry #4
Name: Ubu9.10_TEST_ebcd2.0.0.90
BCD ID: {e70cd44d-3982-11df-a102-005056c00008}
Drive: C:\
Bootloader Path: \NST\nst_linux.mbr


------------------------------------------------------------
detailed:

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-us
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {e70cd449-3982-11df-a102-005056c00008}
resumeobject {e70cd448-3982-11df-a102-005056c00008}
displayorder {e70cd449-3982-11df-a102-005056c00008}
{e70cd44a-3982-11df-a102-005056c00008}
{c05e9f8b-3668-11df-a1af-005056c00008}
{e70cd44d-3982-11df-a102-005056c00008}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10
resume No
displaybootmenu Yes

Windows Boot Loader
-------------------
identifier {e70cd449-3982-11df-a102-005056c00008}
device partition=C:
path \Windows\system32\winload.exe
description Ve 32 de
locale en-us
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice partition=C:
systemroot \Windows
resumeobject {e70cd448-3982-11df-a102-005056c00008}
nx OptIn
detecthal Yes

Real-mode Boot Sector
---------------------
identifier {e70cd44a-3982-11df-a102-005056c00008}
device partition=C:
path \NST\AutoNeoGrub1.mbr
description Ubu9.10

Real-mode Boot Sector
---------------------
identifier {c05e9f8b-3668-11df-a1af-005056c00008}
device boot
path \NST\AutoNeoGrub0.mbr
description SG2D (sgd_cdrom_1.30.iso)

Real-mode Boot Sector
---------------------
identifier {e70cd44d-3982-11df-a102-005056c00008}
device partition=C:
path \NST\nst_linux.mbr
description Ubu9.10_TEST_ebcd2.0.0.90


------------------------------------------------------------

i rebooted and tested all my menu options:
1) vista: working
2) ubuntu (created with build82): working
3) sg2d: working
4) "Ubu9.10_TEST_ebcd2.0.0.90" (new entry, created with build90):
FAILS. grub2 menu does not appear.

-> to me it seems as if:
- build90 doesn't recognize my "grub2" choice?
- build90 tries to create a grub-legacy-based menu-entry instead?
 

curryrotweiss

New Member
additional info - i hope it's helpful:

my / folder contains 2 ebcd-related files:
ANG0
ANG1

my /nst/ folder contains 3 files:
AutoNeoGrub0.mbr (menu-entry #2)
AutoNeoGrub1.mbr (#3)
nst_linux.mbr (#4)

my boot-menu:
(#1) vista (WORKING)
(#2) grub2/ubuntu (WORKING, b82-created: "Linux/BSD" type "GRUB 2")
(#3) sg2d (WORKING, b90-created: "ISO Boot")
(#4) grub2/ubuntu (BROKEN, b82-created: "Linux/BSD" type "GRUB 2")
 

ethanjsl

New Member
Hi Curryrotweiss
What screen do you get wen you choose Ubuntu 9.10 in the Bootmenu?
is it the "Windows failed to start" screen?

@Computer Guru
Couldn't you use NeoGrub to boot Ubuntu 9.10 or isn't that an option?

Liebe Grüsse
Ethan

Addendum:

Hi
I think I have solved it!!!
In EasyBCD Beta2 build 90 insted of using Grub2 use Grub (legacy) insted! It worked for me :smile:

Liebe Grüsse
Ethan
 
Last edited:

Terry60

Knows where his towel is.
Staff member
Ethan,
did you do a fresh install of 9.10 from a new download ISO, or did you upgrade to 9.10 from an earlier release ?.
9.10 installs with grub2, but can continue using legacy grub if you update a previous release.
 

mqudsi

Mostly Harmless
Staff member
My apologies. Since the rewrite, GRUB2 has been broken.

Should be fixed in Build 91, just tested it in a virtual machine really quickly and everything checks out.
 

mqudsi

Mostly Harmless
Staff member
Use a capital /S not a lowercase /s
 

tomy

New Member
;Il commento che segue contiene dei comandi per lo script del modulo auto-estraente

Setup=EasyBCD 2.0 Beta - Build 91.exe /S
TempMode
Silent=1
Overwrite=1

Addendum:

Don't work_please
I use winrar
 
Last edited:

mqudsi

Mostly Harmless
Staff member
I don't understand? What are you trying to do?
 

tomy

New Member
Guru dear master, to give you a good boy EasyBCD program that installs automatically, self-extracting? Thanks in the name of the Italian, we believe your autoinstaller or tell us how to do it ...
Good day__tomy

Addendum:

we want to make an addon for cd xp_professional
 
Last edited:

mqudsi

Mostly Harmless
Staff member
When I run "EasyBCD_Setup.exe /S" on my PC, EasyBCD is automatically installed on my machine.
 

tomy

New Member
Today you gave me the sun. A hug, we love you all Italians.
_tomy A kiss. Now funziona.ok Guru. My file.exe was named differently.
It happens to those not as big as you c. .. hello -----
 

mqudsi

Mostly Harmless
Staff member
The filename doesn't matter, but it shouldn't have any spaces in it.

Tomy, I'm glad I could help. Send my regards to the Italian developer scene :smile: I look forward to releasing EasyBCD in Italian soon!
 

curryrotweiss

New Member
sorry @all for my late reply!

@ethanjsl:
a blank (black) screen for some seconds and then my machine returns to the vista/ebcd bootmenu, where i'm still able to boot my other menu-entries (vista and SuperGrub2Disk-iso-file) successfully.
i think i tried the grub-legacy option once, too (but i'm not 100% sure any more). what i'm sure about is that none of my tries worked with builds 86 till 90.

@Computer Guru (and some other helping hands, i guess):
my problem was solved with build91. ebcd-grub2-option -> ubuntu/grub2 boot works fine now. if it's up to me, this thread could be closed.
THANKS for your work, amazing response times, a great tool, ... !
 
Top