EBDC 2.0b60 crashes on linux tab

#41
Hate to bud in like this, certainly don't mean to hijack the thread, but my issue relates to the topic at hand.... "bootgrabber crashing on linux tab"

Just downloaded BCD 2.0b63 and bootgrabber.exe just crashes when I hit the "Linux" tab.
Tried the bootloader.exe /list command as prescribed here in the thread and it just hangs.

I have a tri-boot system ... well, I would like to have the system to boot to all three OSs- XP, Vista x64, Linux (Fedora) but I cannot get Fedora to start using BCD 1.72 -- at all. XP/Fedora was on my system until I was forced to install Vista for work-related reasons and then used BCD to manage all three... nada for linux. BCD will boot XP or Vista but not linux ...

Grub is installed in its own /boot partition [as a 3rd primary partition - not as a logical drive in an extended partition] hd2,2 (yes, three hard drives) but BCD won't play nice with it for some reason.

XP was installed first, then Fedora, used XP's bootloader but then made room for and installed Vistax64.

Funny how I can manage to install and run DOS, XP, BSD and a couple linux distros on the same system but introduce "vista" on a simple system and everything goes to the pooper.

hd0,0 = c:\ = XP
hd0,1 = vista (vista sees this partition as c:\ and the hd0,0 as d:\) ... welcome to "world according to windows"
hd2,2 = /boot (for fedora)

Any advice?
 
Last edited:
#42
I can't explain the reason why EasyBCD 2.0 Beta Build 63 is crashing like that on you, but try deleting and creating again with 1.7 the Fedora entry, this time making sure to point it at the /boot partition in the Drive drop-down menu underneath the Linux tab, and making sure to not check the "Grub is not installed to the MBR" box before creating the entry.
As for the crashing, it may be you something is wrong/corrupt with your MBR. You can try posting (along with a screenshot of Disk Management) the output of the following two commands run from EasyBCD's Power Console on the Useful Utilities page:

Code:
bootpart
MbrFix /drive 0 listpartitions
 
Last edited:
#43
Thanks for the reply!

Here's what I did since posting about the crashing with BCD v2.0 B63 and before even reading your reply ... (it was a long night!)

I re-installed grub to the /boot partition, then went back and tried BCD 1.72 (figuring that something was up with v2.0B63) but I ended up with more troubles. BCD 1.72 would add an entry but whenever I tried to boot I would end up staring at a blank screen. Something's up.

When I removed BCD and went back to the XP bootloader, I can boot into XP or linux. As soon as I introduce vista and BCD, everything goes fubar. Like I said, it was a long night.

What I'll try to do next is to migrate my linux installation to completely separate drive and then try all this again.

Something weird is happening here. Don't blame BCD - but this vista thing. BCD seems well-suited for multi-booting microsoft products but those products never like playing nice with the "competition".... or so it seems.

----------------------------------

Addendum:

Well, a little update here - I've figured it out!

Problem was that Vista was reading the hardware priority (partition table) very differently from XP (on which partition BCD stores the info - XP is the first OS installed on the first physical hdd, hence hd0).

While XP was reading the partition table in one way - first physical drive as hd0 (on which XP and Vista are installed), hd1 as the second drive (testing drive) and the third drive (hd2) as the third physical drive - all SATA drives hooked up to different controllers on the board - vista has a different interpretation of this. Keep in mind that my Fedora installation resides on the 3rd primary partition of the third physical drive (the drive is physically hooked up to the third controller on the motherboard).

Well .... Vista was reading the partition table a bit differently (read: completely differently). It insists that the third physical drive be listed as the first physical drive (while XP reads the drive hookup correctly), hence according to vista's distorted reality - it sees hd2 as hd0; hd0 became hd1 and hd1 became hd2!!!

Unreal! :wtf:

Go figure.... The world according to windows.

So in effect BCD was reading vista's perverted sense of drive location and was thus feeding the bootloader the wrong information... hence never got to boot Fedora. Once I physically changed the parameters for Fedora's /boot partition from hd2,2 to hd0,2 in NeoGrub everything was ok and now I can triple boot.

Vista is the culprit here. I really don't know what those people in Redmond are eating/smoking/drinking/thinking, but they always find a way to mess things up.
 
Last edited:
#44
Awesome! :grinning: Glad your problem is solved.
Let us know if you have any more questions.