Error 17 -> File not found -> MBR Cylinders (30402) is not equal to the BIOS one (163


Hi! I've got a problem booting into OpenSuse, installed on my second HD.
I installed OpenSuse 11 WITHOUT GRUB, thinking I'd use Neogrub to do the work.
The config file looks like:

# NeoSmart NeoGrub Bootloader Configuration File
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
title SUSE
find --set-root /boot/vmlinuz-
kernel /boot/vmlinuz- ro root=/dev/sdb2
initrd /boot/initrd-
# All your boot are belong to NeoSmart!

The file names are from mounting the Linux-partitions in Vista using Ext2FSD program (note no .img ending on initrd...?)
OpenSUSE installed fine, and managed a reboot after install (how I wonder...?). Everything went smooth so far.
Then when running the SUSE boot option according to above, I get "Error 17 file not found" Using the "debug" option in Grub4DOS and repeating the commands above line per line I see:

"Warning: MBR Cylinders (30402) is not equal to the BIOS one (16383).
Warning: MBR total sectors (488408130) is greater than the BIOS one (488.97168).
Some buggy BIOSes could hang when you access sectors exceeding the BIOS limit
ERROR 17: File not found"

which is identical to and from : ""

In that forum they recommend using an updated version of "grldr", but this file is replaced by "Neogrub" now - or?

I am at loss, how do I proceed. I'm using Vista Home 32 bit Premium, and a HP Pavillion DV9880, and would very much like the 64-bit SUSE to get up and running :wink:

Cheers, Radar
Update: Gave up on Neogrub last night and installed GRUB on /dev/sdb2 using the SUSE installer DVD. Then added the Linux entry using EasyBCD. Now it works! Read on this forum that HP Pavillion will not boot from 2nd HD, that theory can now be scrapped, it works for me. Using latest BIOS for my computer, v58. Cheers, Radar!
Hey Radar, welcome to NST, glad to hear you got it to work.

Thanks for the OpenSUSE info, didn't know they got that particular problem sorted out. :smile: