Error 19: Cannot mount selected partition

#1
Dear folks,

I was succesfull at installing using ubuntu. Could boot to ubuntu and vista through GRUB with no issues.

but i decided to used easybcd to let vista (installed firt) "be in charge" of booting and now i can't boot to ubuntu!

i understand it is because neogrub isnt in the same partition as Ubuntu, and it can't find it.

first, it showed "error 17: File not Found" obviusly, it couldn't find ubuntu's stuff (/boot/vmlinuz-2.6.27-11-generic root=UUID=7d9addaa-ef27-4c88-b7b2-eb4b748a5118 ro locale=pt_BR quiet splash)

my menu.lst was like this:

title Ubuntu 8.10, kernel 2.6.27-11-generic
uuid 7d9addaa-ef27-4c88-b7b2-eb4b748a5118
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=7d9addaa-ef27-4c88-b7b2-eb4b748a5118 ro locale=pt_BR quiet splash
initrd /boot/initrd.img-2.6.27-11-generic
quiet

then i realized i should point some directions to neogrub and changed it to:

title Ubuntu 8.10, kernel 2.6.27-11-generic
root (hd0,5)
uuid 7d9addaa-ef27-4c88-b7b2-eb4b748a5118
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=7d9addaa-ef27-4c88-b7b2-eb4b748a5118 ro locale=pt_BR quiet splash
initrd /boot/initrd.img-2.6.27-11-generic
quiet

and even:

title Ubuntu 8.10, kernel 2.6.27-11-generic
root (hd0,5)
uuid 7d9addaa-ef27-4c88-b7b2-eb4b748a5118
kernel /boot/vmlinuz-2.6.27-11-generic root=(hd0,5) ro locale=pt_BR quiet splash
initrd /boot/initrd.img-2.6.27-11-generic
quiet

I even tryied without the uuid part:

title Ubuntu 8.10, kernel 2.6.27-11-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.27-11-generic root=(hd0,5) ro locale=pt_BR quiet splash
initrd /boot/initrd.img-2.6.27-11-generic
quiet

The only thing that happens is "Error 19: cannot mount selected partition" when i try to boot to ubuntu.

any leads?
thanx for the attention.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi leo, welcome to NST.
Are you using the 2.0 Beta release of EasyBCD ?
The grub uuid syntax used by the latest Linux builds is not supported in earlier releases of Easy.
 
#3
Get [thread=642]EasyBCD 2.0[/thread], remove NeoGrub under the NeoGrub tab, and then try adding a new entry for Linux under the Linux tab, this time checking the box called "Grub isn't installed to the bootsector". And then everything should work fine. :wink: If its still not booting after that, then please post the output of the following command run from EasyBCD's Power Console in the "Useful Utilities" section of EasyBCD:

Code:
bootpart
Cheers,

-Coolname007
 
#4
goin to do that,
got some news though,

used a comand that I saw in another thread
"sudo grub
find /boot/grub/stage1"

and it showed "(hd0,4)" as the place where ubuntu is. (i thought it was hd0,5)

when i tryed to boot with hd0,4 as root the error was "Error 2 Bad file or directory type"
File system is type ext2fs.

which is really strange, cuz grub could boot into it before.

goin to try easybcd2.0 though, will report later

tanx.

Addendum:

It crashes as soon as I go into the "linux" tab in "add/remove entries"

Addendum:

i think i'm goin to delete ubuntu partition and install again.

Maybe i've installed it with ext2, which (again) is really strange cuz ive used it a couple of times

and I did not choose for manual instalation, went for guided and the one which he goes for the largest free space.

PS: i tried for manual, but couldnt. It just wouldnt format a new partition for me, saying that i should correct the setup of file system, something like that.

Addendum:

As strange as it may seem,
Ubuntu is booting now, i really dont know why.

Just reinstalled easybcd2.0 and reconfigured Neogrub wih (hd0,4) as root

here is how it is, in case it can be usefull for developemnt

title Ubuntu 8.10, kernel 2.6.27-11-generic
root (hd0,4)
uuid 7d9addaa-ef27-4c88-b7b2-eb4b748a5118
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=7d9addaa-ef27-4c88-b7b2-eb4b748a5118 ro locale=pt_BR quiet splash
initrd /boot/initrd.img-2.6.27-11-generic
quiet

tanx for the help anyway
 
Last edited:
#5
Glad you got it all booting ok. :smile: Let us know if you have any more questions, or problems.

-Coolname007
 
#6
I had the exact same problem. EasyBCD 2.0 beta build 63 fixed the problem following Coolname007's advice without the need for the NeoGrub.