Error booting Ubuntu 11.04 [Grub 2] with EasyBCD

DuSh4n

New Member
#1
Good afternoon,
I seem to have a problem booting Ubuntu 11.04 32-bit with Windows 7 64-bit.
I followed your tutorial and installed it after Windows (http://neosmart.net/wiki/display/EBCD/Ubuntu), after that I had Grub 2 as default boot manager, after that I used EasyBCD to re-write MBR with Windows 7 Boot Manager and add Grub 2 to it as a second entry. Everything is done as it should be, I made no mistakes, 100% sure. I've already done the same a month ago with Ubuntu 10.10 64-bit and it was okay and working. Now I have the problem that whenever I choose Ubuntu (Grub 2) from the boot menu I get: Try (hd0,0): NTFS5: No ang1 and basically that's all, from that point on I can only shut down my laptop pressing the power button.
What should I do to fix this?

Addendum:

I forgot to add something in the first post.
First, this is the configuration of my Windows Boot Manager:
Code:
There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Ubuntu
BCD ID: {babf4a08-61a6-11e0-bfa5-af188632467c}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub1.mbr
Second, last time when I was on Ubuntu I installed NTFS Configuration Tool and I messed up something and deleted the app. After that I can remember that when I tried to un-mount windows partitions from Ubuntu (partitions were displayed on desktop) I couldn't, it was saying that I must be root. It probably has nothing to do with this but...

Here is also more detailed configuration:

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=\Device\HarddiskVolume1
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {babf4a05-61a6-11e0-bfa5-af188632467c}
resumeobject            {babf4a04-61a6-11e0-bfa5-af188632467c}
displayorder            {babf4a05-61a6-11e0-bfa5-af188632467c}
                        {babf4a08-61a6-11e0-bfa5-af188632467c}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 10
displaybootmenu         Yes

Windows Boot Loader
-------------------
identifier              {babf4a05-61a6-11e0-bfa5-af188632467c}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence        {babf4a06-61a6-11e0-bfa5-af188632467c}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {babf4a04-61a6-11e0-bfa5-af188632467c}
nx                      OptIn

Real-mode Boot Sector
---------------------
identifier              {babf4a08-61a6-11e0-bfa5-af188632467c}
device                  partition=C:
path                    \NST\AutoNeoGrub1.mbr
description             Ubuntu
locale                  en-US
-----------------------------------------------------
Third edit:
I just added a letter to my System reserved partition that was created while I was installing Windows 7 a week ago, after I formatted the whole hard drive. It's not working, should I change something in the EasyBCD configuration now?

UPDATE: IT WORKED AFTER CHANGING SETTINGS IN EASYBCD!!!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Glad you got it to work.