Error Code: 0x80070002 // Vista - Packard Bell

#1
Using Packard Bell - Vista



"Windows cannot open the required file D:\Sources\Install.wim. Make sure all files required for installation are available, and restart the installation. Error code: 0x80070002."

I've been researching this and I found out that the code means missing or corrupted component; my problem is that I cannot access my desktop to fix this.
How do I find out what component is missing and how do I retrieve it?

I am not familiar with this so please do give me step-by-step guidelines


I switch on my computer, ignored the buttons option at the beginning and placed in the Recovery Disc
- clicked a button to boot

Install Windows: Set Languages
- Clicked Next



I understand: "There is no install files on our Recovery CD. You can't use it to reinstall Vista. It is for Recovery Purposes only."

It takes a while to load

- Clicked on "Repair your computer"
- then "System Recovery Options"
- then "Load Drivers"
- None show up so I have to add the drivers to the list [they're all the same file - for sound only ?]

"Windows could not load the installer for MEDIA. Contact your hardware vendor for assistance."



"A hardware disk problem is preventing Windows from installing"

... is there any way that I can repair or re-install my Vista through ?


Even when I go to the Packard Bell Recovery by either F11 or F8 - can't remember which one
I still get a pop-up message that states the same message as above.


So since I cannot add the drivers I was wondering if I could still go ahead with the Open Command section
If so, what do I need to do?

If no, how can I repair my Vista?
I noticed several options at the very beginning of switching on the computer. Is there a way I can use one of them to make the computer work again?



EDIT:
I also read somewhere that "if you're trying to repair a Vista installation, it sounds as though the downloaded ISO file is corrupt. Download and burn it again" - I downloaded the recovery disk from the neosmart website. I downloaded it once // and I would be frustrated to having to pay again to download it again - it hasn't even been 48 hours since I downloaded it
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
If you download from the Neosmart website (the torrent), it's free. The pay link is to another website with more bandwidth.
If the CD boots you don't have a problem with the burn and you don't need a new download.
When you run "repair your computer", it should find any candidate OS to fix. Sometimes it can't because
a) you have multiple HDDs which confuses it, in which case disconnect all the others except the one containing the OS you want to fix.
b) Your Vista partition has lost the "active" flag because you've installed some other OS which has assumed control, in which case flip it back to Vista before doing the repair.
c) It just gets confused (MS wrote the code), in which case try clicking "next" without selecting an OS (don't go on to the load drivers screen). That will sometimes do the first part of the repair and Vista will magically reappear for the 2nd and 3rd times you do "startup repair". (It needs to fix several things, and only does one per pass).
 
#3
I manged to access to my desktop but I think I may have done some damage to the partition
I kept having problems about there not being enough space to carry out the process so I used this:
Using GParted to Resize Your Windows 7 or Vista Partition - How-To Geek

I did something to the /dev/hda2 - I got an exclamation mark next to it
... when I tried to fix it the power cut so I don't know if it went through

I got back on the computer later,
can access the desktop now but I get message:

"Windows detected a hard disk problem"


EDIT:
I followed these steps:

1. Open "Task Manager" and select DFDwiz.exe (if running) and click on End Process.

2. Open "system32" directory, take ownership of DFDwiz.exe

3. Install software like TuneUp Utilities

4. Use the TuneUp shredder to delete that file

5. Restart your system
.... but I have a cross against the DFDwiz.exe

What can I do now?

2nd EDIT:
DFDWiz.exe - How to fix DFDWiz.exe error Fast

Don't say I am not making the effort of fixing it - haha
Still not sure if that will solve all problems though
 
Last edited: