error message

#1
Long story short. Win 7 on vista about a month ago. Worked well. Decided to dump Win7 and install XP in partition where win7 was. Wasn't able to access vista as before with win7. Used vista recovery or repair and could access vista. Hit or miss then when logging in to vista. Xp no access. Installed vista over original vista, it did save settings,etc. saving in folder 'windows.old' on drive C with new vista install. Xp on drive F by the way. Followed the instructions about dual boot vista/xp from 'maketecheasier.com' and downloaded 'easybcd' while in vista. Finally worked out that xp only boots now and saw where I should download 'easybcd' in xp and try to configure. Well problem is................'application failed to initalize properly (0x6000135)' and the program will not start. Again xp boots. Vista negative. Sorry to go in such detail. All help appreciated.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Neo, welcome to NST.
EasyBCD needs NET 2.0 framework installed as a pre-req in XP.
You need to repair the Vista boot, and copy the XP boot files into the "system" partition root, pointing the copy of boot.ini back to the XP partition.
Have a read of the sticky thread, and follow the links to various wiki entries and you'll find all the info you need.
 
#3
Thanks.........did net 2.0, bcd works.
Read the 'sticky'........confusing to say the least.
Saw where bcd2.0 beta available and it can fix .........EasyBCD 2.0 (now available in Beta) will configure boot.ini for you automatically as you add an entry for XP to the Vista BCD, or you can invoke the auto-configurator directly from the "Tools" dropdown menu.

Is this what I should do? Computer management shows disk F xp boot.
Thanks again.

Addendum:

Went ahead and d/l bcd 2.0 beta hoping to get the automatic fix.........no go!!!!!!!!..........then repair vista with install disc............back to where I started. Guess I'll be reading those sticky's,just wish I knew what they mean.Any advise appreciated.
 
Last edited:
#4
Went ahead and d/l bcd 2.0 beta hoping to get the automatic fix.........no go!!!!!!!!..........then repair vista with install disc............back to where I started. Guess I'll be reading those sticky's,just wish I knew what they mean.Any advise appreciated.
Hi Neo.
Did you try adding an entry for XP under the Windows tab in the Add/Remove Entries section of 2.0 Beta, remembering to select the XP option in the "Type" drop-down menu? If so, then what should happen is you will get to a prompt asking you if you want EasyBCD to automatically configure boot.ini for you. Hit Yes, and then XP should be working ok then, assuming of course the XP boot files (boot.ini, ntldr, and ntdetect.com) are located in the root of the "system" partition as shown in Disk Management. :wink:

-Coolname007
 
Last edited:
#5
Solved.......................

Thanks for your help. Worked exactly as you said. I didn't d/l the file and copy to drive F xp as I should. Appreciate your time and advice.
 
#6
No problem. Glad to be of assistance :smile:
Let us know if you have any more problems with booting.

-Coolname007