Error opening registry

Marnes

New Member
#1
Hiya

A while ago, I used Aomei PA to convert my MBR SSD and disks to GPT, with Windows and my Linux distro in place. It worked fine and I could disable BIOS support, I'm now happily using pure UEFI. I then installed a custom bootloader (rEFInd) and tweaked it to my liking. UEFI lists grub and the windows bootloader, refind and various extra options like ext hdd. All seems great so far.

Ever since then though, I get this:
"The parameter is incorrect"
http://i.imgur.com/lW8sI77.png
"Error opening BCD registry"
http://i.imgur.com/OZkk5FW.png
(this error popup is 3x taller than my screen...)

I've been able to boot without issues or anything, and I've already tried a ton of troubleshooting things I've found but can't really seem to get anything to work. I've always failed to understand BCD and its intricacies so now with this I'm totally lost. The fact that I'm seeing all my UEFI-level boot entries in what's supposed to be the Windows-level boot management just confuses me more, looks like spaghetti scopes/entanglement to me.

I'd just like to get rid of those errors and understand why I'm seeing what I'm seeing so that I can customize it to my needs comfortably without thinking I'll break stuff for reasons that aren't obvious to me. From what I understand, BCD is like the data the Windows boot manager uses... So then why is everything from the UEFI level in there too? Did they get in there by some error and do they need to be deleted? Does BCD actually map to my UEFI now, meaning I can change my UEFI's boot options by modifying Windows' BCD or something? Why does bcdedit /enum list only entries that seem legit to me, but EasyBCD's popup shows what seems to be UEFI's config? I'm lost...

FYI I really only need "boot entries" at any level for refind, grub and the main OS entrypoints; I don't need recovery entries, MS' memory analyzer, etc etc.

Thanks for any help/info on this
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2

Marnes

New Member
#5
It's the same error here: https://neosmart.net/forums/threads/easybcd-dont-start.13737/

Maybe a recent Microsoft update broke something in their boot loader code or it's just a really odd coincidence.
I've attached a zipped export of my bcd.
Errorlevel was 1 because it too tells me "the parameter is incorrect".
S:\efi\microsoft\boot has no file called bcd: http://i.imgur.com/HBmEymB.png
The rest of the contents of S: don't seem relevant: http://i.imgur.com/l5pnRlw.png (Boot just contains bootx64.efi http://i.imgur.com/NHFu6Q5.png )

Do you need anything else?
 

Attachments

mqudsi

Mostly Harmless
Staff member
#7
Yup, perfectly in line with xDriiss' experience in the other thread.
 

Marnes

New Member
#9
Bump. Any follow-up, please? :/ xDriss' thread doesn't mention a solution (if it does, it's buried in the French...), so what do I do?