Error When Trying to Add/Remove Entry

For some reason when I click the Add/Remove Entries button on the left, the program crashes, providing the pop up window below. I have tried the program on 3 computers, 2 are identical and both do it, the 3rd is different and it works fine. The problem occurs in both 1.60, and 1.61, but not in 1.52. Any Ideas?

I have 1.61 Beta installed and have sent reports. I just sent another one. The picture is the same for both versions, i just happened to be on the computer with 1.6 at the time.
OK, need some help from you:

EasyBCD | Useful Utilities | Power Console

Can you copy and paste the output in a reply here please?
No problem - you weren't the only one!

Hope you enjoyed Independence Day :smile:

Truth be told, that is an interesting error!
It seems that it cannot see any of the disks/partitions on your machine.

Are you running any special bootloaders? Did you manually recover your MBR? Virtual Machine?

For comparison, here's the output on my machine:
C:\Program Files\NeoSmart Technologies\EasyBCD\bin>bootpart
Boot Partition 2.60 for WinNT/2K/XP (c)1995-2005 G. Vollant (
WEB : and
Add partition in the Windows NT/2000/XP Multi-boot loader
Run "bootpart /?" for more information

Physical number of disk 0 : 1bb91bb8
 0 : C:* type=7  (HPFS/NTFS), size= 64790113 KB, Lba Pos=63
 1 : C:  type=83  (Linux native), size= 52428127 KB, Lba Pos=129580290
Physical number of disk 1 : 5120511
 2 : D:  type=b  (Win95 Fat32), size= 29310561 KB, Lba Pos=63

You say you have two identical machines that do this, and a third that is "different" and doesn't.

When you say "identical" and "different" do you have any idea what difference there is in the configuration/setup? Anything to do with the hard drive controller, the way the OS was installed, maybe?
The 2 machines that are "the same" I meant hardware wise, same innards. the one that is different is a completely different box with only 1 partition on it.

As for the 2 that are "the same" they do have different partition setups (working out a future lab situation) and are both physical boxes.

One of them (the one that i'm not doing most of the stuff with) is just a single partition with Vista on it, but it has received its Vista install from an Image (using SMS 2003).

The one that i'm working with is running easyBCD 1.61 and have 5 partitions on it, the first primary is Vista, the second is Fedora 7, the other 3, in a logical partition, are Ubuntu 7.04, Mandriva Free 2007 Spring, and a linux swap. Each linux has its bootloader installed in its own partition. All were installed fresh from CD, starting with Vista

I just looked at Disk Management under the Computer Management console and recognizes all the partitions, but not what format they are. Any idea how to make it fix that?

Sounds like on the second machine the install from image also copied over the original (non-fitting) MBR?

On your main machine, most likely somewhere along the way one of the Linux installs (or Vista) did something to the MBR as well :/

Since you have a non-standard MBR, first thing is to back it up just in case anything goes wrong:
EasyBCD | Useful Utilities | Power Console
MbrFix /drive <num> savembr <file>

Replace <num> with the drive number(s) (starting from 0) and <file> with the file to create as a backup of your MBR.

Back in EasyBCD, go to Manage Bootloader | Reinstall Vista Bootloader
(Your linux bootsectors will not be affected)

Check if it works?
As for the Imaged machine, the MBR shouldn't have been messed with (SMS does file based imaging inside a partition). But i can see how it may still be a problem.

As for the partitioned one, well, the linux's screwed something up somewhere, i checked in PartitionMagic and it's finding partition errors all over the place, so much so that it can't even pick out whats what. I'm going to try installing everything from the start again, this time partitioning everything out ahead of time. I'll let you know the results.
Best of luck to you - do let me know how it goes.

Anyway, thanks for alerting me to this particular issue - I've never been able to test EasyBCD on a machine without any hard drives before! :tongueout:

But seriously, I'm adding code to the next beta which will detect if the MBR is corrupted just so that EasyBCD won't crash when it happens.

Thanks & good luck!
Alright, after a couple hours of fiddling with things i am back to post my results.

nothing worked, lol.

I first tried reinstalling windows, wiping the entire drive in the process, and installing and running EasyBCD BETA. Still errored out (corrupt MBR). So i figured well, something must really be up with that sector. So i went out and got a utility to zero out the drive and did so. after an hour of zeroing i reinstalled Vista and EasyBCD, and the problem remains. I have no idea why my MBR is being found as corrupt but here's my system layout if it would help.

Vista Business Volume Licence
Dell Dimension 4600 (P4 3ghz)
gig of ram
WD 160gb hard drive - zero'd out, 1 20 gig partition with vista on it. partitions during vista install

I'll continue tinkering and looking, but if you have any idea's, by all means chip them in
Wow, that certainly is intriguing!

It doesn't make any sense.... but it does explain why both PCs have the same problem - seems its something to do with your hardware or HD Controller... :S

Do you have an update for the BIOS?
They should have the most recent BIOS update. I also just found out that my coworker working independently of me ran into the same issue on the same type of computer. We'll be getting new computers this summer, so hopefully the problem will go away when these computers go the way of the dinosaurs. thanks for all your help, this is the best tech support for a piece of software that I've ever found.
Thanks for your kind words, youngsnowman.

If you'd like to get to the bottom of this, I'll be more than happy to help in any way I can; but I don't know, it may not be the worth the effort if a new PC is on its way :smile:

I'd say send Dell an email, sounds like a rather big issue to me; they must have heard of it by now.