Fedora 16 Troubles

Acrob

New Member
#1
I have recently installed Fedora16 x64 , the machine ‘s configuration is
3 HD’s partitioned as follows

hda1 (Ntfs Win7x64) / hda2 (Ntfs WinXp) / hda3 (Logical for data)
hdb1 (Ntfs Win7x64) / hdb2 (Linux Swap) / hdb3 (ext4 Fedora with Grub2) / hd4 (Logical for data)
hdc1 (No partitions, used for backups)

To the problem now, no matter what option I use in the easybcd add entry the machine won't boot into Fedora,
by the way where is this wonderful option Dissent found “adding Fedora to the list with GRUB Legacy” ?
http://neosmart.net/forums/showthread.php?t=8960&highlight=fedora
I am using EasyBCD 2.1.1 and the list with GRUB (Legacy) has these entry’s

GRUB (Legacy)
GRUB2
LILO/eLILO
Free BSD/PC-BSD
Wubi
SysLinux

So I tried to recreate the issue with a Virtual Machine
The machine has 2 HD’s partitioned as follows to much the reall one

hda1 (Ntfs)
hdb1 (Ntfs) / hdb2 (Swap) / hdb3 (ext4, again the Grub2 installed here)

Same issue appears no matter the compination used
GRUB (Legacy) -> GRUB_ prompt
GRUB (Legacy) checkbox ticked -> Error 15: File not found
GRUB2-> grub> prompt

After some further experiment’s (just killing time:smile:)
-Installing Fedora 15 -> booting success! Using this guide
http://thpc.info/dual/win7/dualboot_win7+fedora15_bcd_on_win7.html
-Instaling PLoP option -> booting success! With Fedora16 I manually choose the partition, but there has to be a better way than these workaround.
 

mqudsi

Mostly Harmless
Staff member
#2
Is Fedora 16 using GRUB2 now?
 

Acrob

New Member
#3
Yeap , i can comfirm that Fedora is using Grub2 instaled in a folder named Grub2 , it is also creating a folder named Grub but that is empty
 

mqudsi

Mostly Harmless
Staff member
#4
There you go. Using Grub Legacy will never work.

Do you know the path to the grub2 menu file? If you don't, I can research it myself when I get the time.
 

mqudsi

Mostly Harmless
Staff member
#6
It's /boot/grub2/grub.cfg

Addendum:

Can you browse /boot to find a file with a name similar to core.img?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
Great.

Create a NeoGrub entry with this inside:

Code:
find --set-root --ignore-floppies /boot/grub2/core.img
kernel /boot/grub2/core.img
boot
And test it.