Fedora 8 on 2nd Drive; Vista on 1st

#1
I have Vista installed on Drive C: and Fedora Core 8 installed on Drive D:.
I installed Fedora Grub on Drive D: bootsector, as shown in the instructions about EasyBCD and Fedora.
When I boot into Vista and start Easy BCD I go to the Add/Remove Entries section and select the Linux Tab. I get these choices in the Drive field:
Drive 0
Partition 0 (HPFS/NTFS - 112GB)
Drive 1
Partition 0 (Linux native - 0GB)
Partition 1 (???? - 28GB)

I have tried both Partitions on Drive 1, but neither will boot Fedora. I am curious about the question marks in Partition 1. Does that indicate something wrong with the installation? I have installed twice now with the same results. During the Fedora installation it asked what drive I wanted to boot Fedora from. I selected sdb (Drive D) Was that the correct choice?
I tried NeoGrub also because it sounded promising but could not determine how to configure it successfully.


Thanks for any ideas or help!
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2

mqudsi

Mostly Harmless
Staff member
#3
I think he's already tried that (going by the reference to the EasyBCD Fedora instructions).

It looks like there is something wrong with your MBR configuration... Do you really have a 0GB linux partition?
 
#4
That is what it shows in EasyBCD 1.7.1 How can I see my Linux partitions? I probably need to reinstall Fedora?

Addendum:

Makaveli213,
Yes, I followed the Fedora specific instructions. I was excited when I saw them because I thought it was the perfect way to dual boot Vista and Fedora. Maybe I made a wrong choice somewhere in the steps, but I have been through them several times now. I picked the selection to remove all Linux partitions and set up a default configuration. I previously has Xandros installed on my second drive and dual-boot with it and XP was pretty easy. Vista is a different story.
Thanks,

Addendum:

Another clue:
During boot up I can hit Escape and select a boot device on the fly. When I do that and select my second hard drive I get this:
Verifying DMI ool Data ..............Update Success
GRUB Loading stage2...

And that is as far as it gets.
Thanks.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#5
Ah, I think Fedora created a Software LVM RAID partition for you..... that would explain the 0 GB partition and the MBR issues.

Reinstall Fedora, but this time manually create the partitions. Just make one big ext3 partition and optionally a SWAP partition as well. Don't let it create a LVM RAID setup for you.

Addendum:

Yep, seems like LVM doesn't work well with your current harddisk/mobo setup; or perhaps conflicts with your existing MBR configuration.
 
Last edited:
#6
You're right - Fedora did create LVM. I am re-installing right now and will let you know how it goes with manual partitions. I will follow your guide.
I appreciate your quick and clear responses!
Sincerely.

Addendum:

By the way if you are still around - what drive should I select for the question:
"What drive would you like to boot this installation from?"
I have drive "sda" My Windows drive and
drive "sdb" My Fedora drive.

Thanks!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
You had to post a minute after I went off to bed, eh? :wink: (3:27AM)

Are you referring to this question?
 
#8
It's the one before that one. I selected to boot from /dev/sdb
This time I manually created the partitions: /, /boot and swap, and installed GRUB to the bootsector.
Now I have tried using EasyBCD to boot Fedora from each of those and none of them work. Each one gives a different error.
Here is what I have in EasyBCD Add/Remove Entries now:
Drive 0
Partition 0 (HPFS/NTFS - 112 GB)
Drive 1
Partition 0 (Linux native - 0GB)
Partition 1 (Linux swap - 2 GB)
Partition 2 (Linux native - 26 GB)

When I select Partition 1 (LInux swap - 2 GB) I get this:
BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant BootPart
Loading new partion
Bootsector from C.H. Hochstatter
Cannot load form harddisk.
Insert Systemdisk and press any key.

------------------------------------------------------------------
When I select Partition 0 (LInux native - 0 GB) I get this:
BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant BootPart
Loading new partion
Bootsector from C.H. Hochstatter
GRUB _
-------------------------------------------------------------------------------------------------------------
Here is my /boot/grub/menu.lst
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinux-version ro root=/dev/sdb3
# initrd /initrd-version.img
#boot=/dev/sdb1
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.23.1-42.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.23.1-42.fc8.img
title Other
rootnoverify (hd1,0)
chainloader +1
---------------------------------------------------
Thanks!
 

mqudsi

Mostly Harmless
Staff member
#9
Well, you can take a shortcut:
Install NeoGrub in EasyBCD, and overwrite its configuration file with what you just pasted above.
 
#10
I am going to try again. I re-read one of your posts and realized you said to make one big ext3 partition and perhaps a swap. Let's see how that works!

Addendum:

Hi I just got your latest reply
I will try the NeoGrub solution first since that will be quicker
Thanks!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#11
Yeah, there is no need for a separate /boot partition.
Just /

I take it you installed GRUB to the bootsector of hdb1?
 
#12
Yes, Installed GRUB to the bootsector of hdb1 (/dev/sdb1)
I just installed NeoGrub and put the above menu.lst in its configuration file and now I get:
Booting 'Fedora (2.6.23.1-42.fc8)'
root (hd0,0)
Filesystem type is ntfx, partition type 0x7
kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/rhgb quiet

Error 17: File not found

Press any key to continue...
---------------------------------------
Something that is bothering me is "root (hd0,0)"
I thought that (hd0,0) would be my C: drive, where I have Vista. Is it looking for the Linux kernel there?
 

mqudsi

Mostly Harmless
Staff member
#13
That configuration file is pretty whack, now that you mention it :\

Give this one a shot?

Code:
default=0
timeout=5
title Fedora (2.6.23.1-42.fc8)
find --set-root /vmlinuz-2.6.23.1-42.fc8
kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.23.1-42.fc8.img
 
#14
Excellent!
Thank you very much! That little config file for NeoGrub worked...
I have been working on this for days and almost gave up last night.
Thanks for such wonderful help.
Sincerely,
Dave

Addendum:

You are right - this is a beautiful interface!
I love that Firefox is already installed.
My first updates are being installed right now.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#15
Hey Dave, that's great news!

I'll be filing a bug with the Fedora community with regards to the errors in the generated menu file so this hopefully doesn't happen in the future.

Enjoy Fedora, it's an excellent distro.
 
#16
Vista system wont dualboot Fedora8

Dear moderators, guru's, and BCD wizards,

I've been having the same troubles as 'dstrick64' as posted in this thread.

After installing EasyBCD and attempting to boot Fedora I received the same Bootpart error's as before. I tried installing NeoGrub with the config script that ComputerGuru pasted. Now, Vista bootloader starts and loads NeoGrub, however I am getting a new error:

"unable to find vmlinuz-2.6.23.1-42.fc8" or something along those lines.

What have I done wrong?

I have 2 HD's. #1 is Vista, #2 is 2 partitions. I installed Fedora with "one large ext3 partition and one smaller swap" method.

Could this have to do with the jumper setting on the HD itself?

Thanks for your time! Much appreciated!
-Nathan, linux wannabe newbie
 

mqudsi

Mostly Harmless
Staff member
#17
Last edited:
#18
Dear Computer Guru,

Background info:
- 1 SATA hd, 1 PATA(IDE) hd - primary ide channel
- Vista recognizes my IDE disk as Device 0 and SATA as Device 1 (I think this is a problem?)


I have tried the SuperGrubDisk to reinstall GRUB to the bootsector of the linux native partition. Also making it an 'active' drive. After reboot, GRUB loads and tells me it can't find the file. I edited the root(hd0,0) command to root(hd1,0) which is where it is supposed to be. The kernel fails to load and completely hangs. There is also a message about a failed swap /sdb1.

I have also tried setting EasyBCD to load Fedora from the MBR by ticking the "Grub is not installed to the bootsector" option.

I don't know where to proceed from here. I have tried to load Fedora from all linux partitions with no luck.
I think the mix of IDE and SATA drives might be posing a problem for Vista, have you heard of such issues?

Should I use a hardware adapter to make the IDE drive into SATA?

Any ideas would be of great help!!!
Thanks again, for your time and patience!!! :smile:
-Nathan
 

mqudsi

Mostly Harmless
Staff member
#19
OK, here's the thing: "the file" - who decided what that file's name is? Is this the one you cut and paste from this thread, or is this the file that Fedora automatically picked?
 
#20
Greetings,

Well this is the error I receive when rebooting after using EasyBCD. I can press a key and grub will load. I then change the root command to root(hd0,0). It says loading Fedora etc, then the screen is filled with long hex numbers and the final error is "attempt to kill initrd" and hangs.


BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant BootPart
Loading new partion
Bootsector from C.H. Hochstatter
Cannot load form harddisk.
Insert Systemdisk and press any key.


It seems like Vista makes the IDE drive Device 0, and Grub makes the Sata into /sda which is the same as device 0 isn't it?