Fedora upgrade, GRUB in MBR and first sector?

#1
So I upgraded to Fedora 16. This was on a dual-booting Windows 7 64bit/Fedora 15 32bit Dell Latitude.

I had a reason to upgrade to F16 and decided to do this through the pre upgrade facility. That went fine... except this apparently did updated the boot loader outside of the configuration provided by EasyBCD.

Now, I get one boot screen with the standard list of Fedora kernels with an option for my Windows 7 partition. This is okay, but if I select the Windows 7 partition, i'm presented with another boot screen.

I think this is the result of the F16 upgrade writing an updated GRUB to the MBR and not the first sector of the boot drive, as I had previously done when installing F15 and setting up Dual Boot (based on the recommendation of several Linux sites that cautioned putting GRUB in the MBR as Windows and Windows partner applications have a reputation of writing files to the MBR on upgrades or for other reasons).

I want to get rid of one of these boot choice screens.

Any hints? And I apologize for possibly posting a question answered elsewhere, but I don't know how to describe this issue, so I'm not sure I was looking in the right place, or searching on the right key words.

Thanks,
Tim
 

Terry60

Knows where his towel is.
Staff member
#2
Either EasyBCD > BCD Deployment > Install Vista/7 bootloader > write MBR If you want to put Windows back in control, or
EasyBCD > Edit Boot Menu > default W7 > skip boot menu > Save settings if you just want to suppress the 2nd menu and leave grub in control.