Fixing the Vista Bootloader/MBR

#1
Hi. Some days ago I installed Ubuntu. I thought I told it not to install GRUB to the MBR but it did so anyway. So I tried to restore the Vista bootloader to MBR today by using EasyBCD but after the two first dialogs (where I chose C: in both) I get an error. "The store import operation has failed. The volume does not contain a recognized file system. Please make sure that all the required file system drivers are loaded and that the volume is not corrupted." How can I fix this? Can I fix it? (or am I locked to GRUB forever?)
 

mqudsi

Mostly Harmless
Staff member
#2
Hi soilheart, welcome to NeoSmart Technologies.

Which option did you choose? Under those circumstances, the correct course of action would be Diagnostics | Reset BCD Data. (not recreate!)

Is that what you did? EasyBCD 1.7?
 
#3
Oh, sorry I forget to describe it better =P

When I start up the program it compains that "Valid BCD Registry not Detected" and asks me if I want it to "correct these issues". If I choose yes it asks me for boot drive and drive with Vista on it. And then fail with the message i posted before.
If I answer No or Cancel somewhere it just closes the program (dialogs).

And it's EasyBCD 1.7 all right.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
I think you're going to have to change the active partition... Use GParted in Linux and make sure that the Vista partition is set as active.
 
#5
Ok, I thought about if it was something like that... but will GRUB still work then? Will I be able to boot into Vista without the DVD? (I only have recovery CDs)

I could try as I have the gParted LiveCD, but It feels better to ask first =P
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Either the Vista bootloader or GRUB will work. I don't think it'll make them both not work.
 
#7
Problem solved.
It hadn't installed GRUB to MBR, ubuntu had just made the ubuntu partition the active one (activated the boot flag on it) so the windows MBR which just boots the active partition booted the ubuntu partition where I had installed GRUB.
A quick google search came up with some ppl who said that the hibernation file must be on the active partition. And as windows couldn't access the ext3 partition it couldn't hibernate.
 

mqudsi

Mostly Harmless
Staff member
#8
Yep, just as I had expected.

I'm not sure why Ubuntu made itself the acitve partition... it's not supposed to.
 
#9
Yeah, it is kinda odd...
Maybe because I said no to install to MBR or something...
(Because from what I've understood GRUB doesn't care about the boot flag at all)

But then again. It was nice enough to add a vista option to the boot menu so it's probably intended behaviour. (So a normal user can install ubuntu and run it without having to change anything no matter if GRUB is installed to MBR or not).

And thank you =P
(You answered my questions faster than the ubuntupeople =) )