Forced image restore; now stuck at blinking cursor

Hi! :smile:

So, I'll start from the beginning, but make it short: my partitions weren't aligned (even with a fresh install of 7), I used Gparted to align them, this destroyed my Recovery Environment 100MB partition, I formatted and did a reinstall, got it back, I then tried an image I had made to restore my work, I got an error "The parameter is incorrect"; 0x80070057, I formatted again, and used this command to force the restore:

wbadmin start recovery -version:12/23/2007-05:59 -itemtype:volume -items:c: -backuptarget:h: -recoverytarget:c:

It seemed to work, it copied all the files. I now have 38GB full on the C:/ partition (according to GParted) which is what I had before I formatted. However, now I am stuck at a blinking cursor on bootup. I tried Startup Repair which found some broken things and fixed them, yet I still cannot boot. As of now, Startup Repair thinks the OS should boot successfully. Startup Repair also now fully recognizes my old install and even the drive label I put on.

I tried ALL the steps on this Wiki:

Even the nuclear holocaust, but with no avail. I'm still at the blasted blinking cursor. Bootsect gives me an error about "access is denied" UNLESS I run with the force argument as well. Chkdsk also tells me that the drive is write-protected?

I'm at wits end. I've tried every site imaginable, I've looked at the TENTH page of Google's search results, I've posted on three forums. I thought I would try here, too.

Thanks in advance! :smile:


P.S. Should I try the image restore again? Maybe with all the tweaking I've done, I've royally screwed something up. To make a list of starting ALL over:

Format the drive (how?)
Use my jump drive with Vista Recovery on it (I can't use CDs...image is also on a disc and I can't eject in the recovery environment)
Try the tool for image restore, if not just use the command prompt to force
Startup Repair/Wiki ideas

P.P.S. Sorry! Just one more thing. I think me forcing the image has not done well. I tried for two days to see if I could figure out the 0x80070057 error, but no luck at all. Even people with the exact same problem as me had solutions that did not work for me. :frowning:


I fixed it. It's doing the image restore now.

I called MS and they told me that you can't do an image restore unless ALL the drives are exactly as they were (and presumably partitions, too). Meaning when I was using my jump drive to initiate the recovery (because I can't eject the recovery disk to put in the image disk), it was counting that as a drive. So no go on using a jump drive to initiate the Windows Recovery Environment. That was what was the "the parameter is incorrect; 0x80070057" error.

I figured out a workaround that I should have seen INSTANTLY. All this time, it's been there. When you're selecting an image, Microsoft realized some people might have their images on external drives which require special drivers. You just go there and wala, you see a Browse icon. Go in there, right-click the optical drive, eject, put in the one with the image.

It's restoring now.


And, btw, if you were wondering, 3 is the limit of times you can clean install from an upgrade disk on 7. I had to call and get that working,too.

Last edited: