Frozen mbr

#1
My Acer Aspire notebook, which runs on Vista, has two 500GB hard drives. Since disk 0 already had four primary partitions I moved one of them to the other drive to make room for a new partition where I could dual install XP. However, when I divided 5GB off the third partition for the XP OS I found that the remainder of the partition, around 300GB, was still of the type 'compaq setup' which has no letter and therefore cannot be used for data. The partition is empty and wiped but every time I try to change it to a regular primary it reverts to the hidden compaq type.

Is it possible that the resistant type designation is set in the mbr and, if so, would it be possible to put things right using EasyBCD? Any and all advice would be very much appreciated.

This is my first post (ever) so I apologise in advance if I have not followed the proper protocol.
 

JustinW

Super Moderator
Staff member
#2
That partition is an OEM partition as you stated. Be warned that messing with it could mean that you won't be able to use features such as a recovery or utility partition if you get rid of it. If you wish to continue, boot from a Vista DVD and use diskpart from the command line, filling in x with your disk number and y with the partition:

Code:
diskpart
list disk
select disk x
list part
delete part y override
exit
It should warn you, but hit y at the prompt and enter to force deletion of the partition. If you have trouble booting after this, use startup repair.
 
#3
Thanks Justin for your very speedy and helpful reply. I did as you suggested and it worked like a charm, except that when I restarted the computer it reverted to the original EISA designation. That seems to suggest that something, perhaps in the MBR, is overriding the Diskpart override. Do you have any suggestions about defeating this?
 
#5
Thanks again for your speedy response. I've seen references to EasyBCD and so, following your advice, I downloaded it. However, I am not clear what exactly 'start up repair / reinstall Vista bootloader' refers to. Is it a process that is managed within EasyBCD? I think I'm almost there but I just need a pointer to the next steps that are not quite obvious to me.
 

Terry60

Knows where his towel is.
Staff member
#6
Jus is refering to this
 
#7
Thanks Terry. Upon reading the EasyBCD guide material in the link you sent it appears to me that EasyBCD would restore the original MBR and so take me back to the OEM configuration where I started. The 300GB partition in question is now empty and I want to use it for data. To do this I have to remove the EISA designation (also referred to as 'compaq setup'). I can do this but the problem is that when I restart it is reset to the protected type. It is this reset that I am trying to override.
 

Terry60

Knows where his towel is.
Staff member
#8
Have you tried downloading yourself a free bootable copy of Gparted and resetting your partition with that ?
 

JustinW

Super Moderator
Staff member
#9
I had Acronis Startup Manager installed once and it used to boot from its own partition before booting Vista, but one day I decided I didn't need it and uninstalled. I ended up using EasyBCD to fix it so it just started Vista. EasyBCD should put the proper boot code in the mbr for Vista. Now whether or not it'll fix your partition issue I do not know, but its worth a try anyway. You could also give gparted a try as Terry suggests.

The hard semi-painful method:

If you got imaging software such as Ghost or Aronis True Image, what you can do is do a disk image to a backup file. Than you can use MBR Wizard, found here, to wipe the mbr. This will cause you to lose your partition table when the machine is rebooted, but if you restore your partitions only without the MBR (Acronis anyway allows you this option), you should be able to use startup repair with your Vista DVD.

The hard painful way:

Wipe the whole disk and re-install.