Ghost entry

#1
Solved:Ghost entry

Hello all,

This is a purely cosmetic problem as my dualboot works flawlessly. The problem, and it's driving me bonkers, is that during boot there are three entries to choose from.

First is Vista, second is Ubuntu (which chainloads grub) and third is another entry for Ubuntu, which does not exist.

I start EasyBCD to remove the dead entry, but all it shows are my two working entries.

Where is that third entry coming from and how can I remove it?

Thank you for your time and response.
 
Last edited:
#2
Hello dgoose, welcome to NST.
The only thing I can think of is perhaps you have a boot.ini file that has a line like this at the end:

C:\ubuntu.lnx="Ubuntu Linux"
This line will cause an entry called "Ubuntu Linux" to appear in your Vista boot menu, if you also have an XP entry in your BCD. But you didn't mention anything about XP...

And that has to do with Bootpart.

That is the only time I have ever seen a case where an entry that shows up in the Vista boot menu does not show up in EasyBCD. Other than that, your guess is as good as mine...:wink:

Jake
 
#3
Hello Coolname007 and thanks for the quick response.

You appear to have hit the nail square on the head.

I did have XP installed alongside Vista and Ubuntu around this time last year. A couple months ago, I decided I could go without XP. So I removed it, screwed up my MBR in the process and only now got it to boot back into Ubuntu without having to use SuperGrubDisk.

Here's what is in my boot.ini file:

;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT
c:\wubildr.mbr="Ubuntu"
Now, do I delete the whole file, or just that line?

Edit: Backed up and deleted boot.ini, ghost entry is gone and everything still works.

Thanks again for the help.
 
Last edited by a moderator:
#4
Great! :smile: Let us know if you have any more problems.
You could have technically removed the last line in the boot.ini file, and that would have removed the surpus entry in your boot menu, but since you got rid of XP, no harm done in deleting boot.ini...:wink:

Cheers!

Jake
 
D

DeanGraziosi

Guest
#5
Hello....


I have recently updated w/ service pack 3 (windows Xp media center edition) and it caused to crash my computer. So i restored it, now my problem is that in my circle it still shows my computer from when it crashed. So i have 4 computers in my circle now. It wont let me remove this PC for some reason. i have paid the 50 doallars for the 3 pcs, but it shows the same computer twice.

Give me reply soon....