Grub Issues?

#2
Also, just a little additional info:

I have Win XP and Win Vista running on partitions 1 and 2 of a SATA drive

When I installed RHEL, I created 4 additional partitions on that drive (/boot, /, swap, and /data)

/boot is on the 3rd partition.

Hope this info helps. I purposely chose not to install a bootloader, thinking EasyBCD would do everything. But, maybe I did need the bootloader installed?
 
#4
Sorry, guess you can tell I'm a bit bored today. I also figure that providing as much info as possible will make it easier to help me out. I'm attaching my partitions screenshot, so you can see how the drive is laid out. Disk 0 turns out to be my zip drive, not sure why, but maybe that's an important piece of info to have when troubleshooting this.
 

Attachments

mqudsi

Mostly Harmless
Staff member
#5
Hi Deker, welcome to NST... Sorry for the delay :smile:

What you need to is install "NeoGrub" from the add/remove entries screen, and the press "configure" to set it up.

The neogrub setup file is a standard grub config, you can use these instructions to aid you until the documentation goes live:
http://www.linuxjournal.com/article/4622

Good luck, and post back & let us know how it goes.
 

mqudsi

Mostly Harmless
Staff member
#6
PS, the section you need is only the one about the menu, you can safely ignore the rest. As a matter of fact, you must.
 
#7
Hi CG, thanks for the reply. I read up on the website you provided and came up with the following menu.lst file for my particular setup:

# /boot/grub/menu.lst
# grub boot menu configuration

# general configuration:
timeout 10
default 0
color light-gray/blue red/light-gray

# boot stanzas follow
# each is implicitly numbered from 0
# in the order of appearance below

# (0) Red Hat Enterprise Linux (default boot):
title Red Hat Enterprise Linux
root (hd0,3)
kernel /vmlinuz root=/dev/sda6 ro


# end file menu.lst



Let me know if you think this sounds correct. I will give it a try later tonight and will report back with the results. Thanks!
 

mqudsi

Mostly Harmless
Staff member
#8
Looks good to me :smile:
 
#10
Okay, tried one last thing...I recopied the Stage1 file directly from the Program Files folder where EasyBCD is installed. Got a GRUB prompt with nothing else. menu.lst file is as follows:


# NeoSmart NeoGrub Bootloader Configuration File
#
# This NeoGrub menu.lst file should be located at \NST\menu.lst of the boot drive.
# Please see the EasyBCD Documentation for information on how to create/modify entries

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,3)
# kernel /vmlinuz-version ro root=/dev/hda2
# initrd /initrd-version.img

#boot=/dev/sda6

default=1
timeout=5
splashimage=(hd0,3)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux
root (hd0,3)
kernel /vmlinuz* ro root=LABEL=/ rhgb quiet
initrd /initrd*.img



Screenshot of the error is attached (hope these files are properly viewable)
 

Attachments

mqudsi

Mostly Harmless
Staff member
#11
Try removing and re-installing NeoGrub.
 
#12
Tried this, didn't work.

I also installed Mandriva 2007 in case it was just an issue with Red Hat Enterprise, no good. All I get is a blinking cursor with a black background.

I tried also booting into Linux rescue mode and grabbing the 512 bytes of the bootsector on the Linux drive. I then created a bootloader entry pointing to that 512 byte file - still didn't work.
 
#13
Hi CG, I believe Mandriva uses a stage 1.5 file, so that's probably why it didn't work. Any thoughts on when EasyBCD will support that type of booting?
 

mqudsi

Mostly Harmless
Staff member
#14
Sorry for the late reply, deker.

It all depends on what your filesystem is.
NeoGrub is platform independant, so long as your filesystem is ext3fs or something similar.

What is your Mandriva partiiton formatted as?