Grub not loaded

#1
I followed the steps described in http://neosmart.net/forums/index.php?gettopic=536 to install grub on my (hd0,8) and also adding an entry into the windows boot loader using easybcd 1.6.

When I reboot and do an Ubuntu selection, it doesn't load the grub.

It displays the following message and sits quiet.

Loading newpartition
Bootsector from C.H. Honst...


I performed the following steps when booted into Ubuntu using live CD:

sudo grub
>find /boot/grub/stage1 returned (hd0,8)
>root (hd0,8)
>setup (hd0,8)

all ran successfully. But still I'm unable to boot into Ubuntu.

Any help is appreciated.

Thanks
Sudheer
 

mqudsi

Mostly Harmless
Staff member
#2
Just to be sure: you first istalled GRUB THEN you did the EasyBCD thing, right?
 
#3
Yes, I did the same.

When I tried easybcd for the first time, after installing grub, it throwed an exception:

"object reference not set to an instance of an object"

Then I removed the entry, booted into safe mode, loaded grub again, then tried adding a entry using easybcd. It didn't throw an exception then, but it didn't boot either.

--Sudheer
 

mqudsi

Mostly Harmless
Staff member
#4
Delete all "BOOT" folders from your hard drive and run Diagnostics -> Recreate BCD Files
 
#5
Are you talking about Windows/Boot or Windows/System32/Boot ?

I tried running diagnostics, but it throws an error : its unable to detect the drive letter of the boot device. But it still erases the BCD entries. Recreating the entries is of no help either in getting into grub.

Here is the snapshot of the error, easy bcd throws.
 

mqudsi

Mostly Harmless
Staff member
#6
C:\Boot.

Windows\system32\boot MUST remain intact.
 
#7
I deleted all the C:\boot* files, and recreated them using easyBCD.

It has no effect on the working :frowning: It displays the following message when I try to load grub and halts.

Loading newpartition
Bootsector from C.H. Honst...

What else could be the problem ?

Is it something to do with the grub ?

Should the following command succeed after setting up grub ?
$sudo grub-install --recheck '(hd0,8)'

Thanks
Sudheer
 

mqudsi

Mostly Harmless
Staff member
#8
It depends where you are installing it from.
If you booted from a Live CD, that'll never work. You have to mount then chroot the actual drive.


The recommended method is to run
Code:
grub
find /boot/grub/stage1
root XX
setup XX
setup XX
where XX is the output of the `find` command.