Grub2 not found, logical partition

#1
Hello,

I use Truecrypt on Windows 7 (system partition encrypted) and ubuntu 10.10 (encrypted). ubuntu and the separate boot partition are on ext4 filesystems on logical partitions.
I made a boot entry with GRUB2 in easybcd. However, it seems that it can't find GRUB2. After chosing "ubuntu" and hitting enter, an error message of the "Windows-Start-Manager" appears,
with the text "Error while starting windows" (translated from German)..
file: /neost.... (something like that)
...
Info: The entry could not be loaded, because the application is missing or corrupt."

The ubuntu boot partition is not encrypted. After the running system with GRUB2, i encrypted Windows and installed the Truecrypt Boot loader that way. After pressing ESC in the Truecrypt boot loader, GRUB2 did not show up, other than expected, so i tried EasyBCD.
 
#3
works partly

Thank you so far, and thank you for the welcome!

I have updated to the beta version. Now it can find grub2 after entering my password in the Truecrypt bootloader. If I don't enter it, it cannot find grub, because the file of EasyBCD, that looks for grub2, is still encrypted. If I remember correctly, it was not able to do find it in any case before.

Now I would have to install it on another partition, so that I dont have to enter the other password first, and in ubuntu the second.

However, there is a bigger problem: There is no Windows 7 entry any more in the bootloader, so I cant boot Windows, because after the Truecrypt loader, the bootloder of Windows/easybcd appears. Maybe I deleted the Windows entry. When pressing ESC in the menu, the notebook resets, starting again with the BIOS booting... .
I have also an entry "NeoGrub Bootloader" available, that shows me a grub shell.
How can I now insert a Windows entry in the bootloader menu again, maybe with a Windows live CD?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4

mqudsi

Mostly Harmless
Staff member
#6
If the TrueCrypt bootloader is working fine, yes you can omit that step.
 
#7
First of all, I want to describe how a made the bootable recovery disk, which was not so easy, for everyone with the same problem.
As described in the manual linked above, I obviously had to get this bootsec.exe on the DVD. Downloaded EasyBCD to ubuntu, and extracted it with WINE. Than I used ISO master for ubuntu to add it to the image. However, when I tried to boot from that burned disc, the "Error Code: 5" appeared. Seemed to be dependent on the hardware, Lenovo notebook. I used this manual UNAWAVE - Code 5 Error beim booten von Windows 7 DVD (German, found also one in English) to get a Windows Vista bootsector on the Windows 7 Recovery Disk, using ImgBurn emulated with WINE to add the bootimage from vLite. Had to burn it with the ubuntu CD writer, because my burning device was not detected by wine.

Then, when I was on the prompt finally (so this disk was bootable), it could not detect the Windows installation. Of course, I noticed, because it is still encrypted. So I cant edit anything of the bootsector, I guess.
So how can I make this work? I read about a possibility to boot an ISO with grub. Or should I decrypt the Windows 7 installation with the Truecrypt Rescue Disk (hope I still have it)?
 
#9
I have a new idea. I could already mount the Windows 7 partition into ubuntu, using Truecrypt for Linux. Now I could just copy working bootloader files into the right directory, couldn't I?

If yes, what files do I need to replace, where do I get them from and in what directory do I need to copy them into?
 

mqudsi

Mostly Harmless
Staff member
#10
Can you connect the drive to another *Windows* PC?
 
#11
No, I would not have been able to do it, at least not all the time. Wouldn't it be possible without one?

However, I have successfully decrypted the drive and used the Rescue Disk to automatically add a Windows entry to the loader. That worked, without using the prompt. Strange enough, I pushed the NeoSmart Linux up in the menu and set it as default. After that, the very first error message I had, reappeared. Another entry of the same content, NeoSmart Linux with grub2, worked.

Thanks to everyone.