HDMI Sound problems with Vista

#1
I have Vista SP1, an ATI HD2400XT graphics card, which is also supplying sound to my AV amp, plenty of memory, dual cpu etc.

The problem I have is that, although the sound I get is perfect in all the usual frequencies (low, mid and top) there appears a further upper layer (thats the only way I can describe it) which has a kind of ringing sound and speech becomes very hissy. I can cure this by rebooting the pc when I can then play an avi/divx/dvd etc perfectly well, but as soon as I close down the file I'm watching and then open another file I get the sound problem. Again this is curable by rebooting, but that is obviously not what I want to keep doing.

Anyone have any ideas?

Further info: I have gone through the (very basic) windows sound config dialogue boxes and checked theat HDMI is being used (although its saying I only have 2 speakers when I actually have 8). I have the latest ati drivers, the latest Realtek AC3 (ati specific) driver 1.89. I use any of PowerDVD 8 ultra, divx player, Cool DVD, Jet Audio or Windows Media Player and have the same problems with each. I also have an output from my cable tv box going through the AV which has perfect sound all the time so its not the AV.
 

mqudsi

Mostly Harmless
Staff member
#2
I experience this myself with HDMI audio on Vista, but I don't have to restart to get it to go away - just stop everything that's currently making sound and then start them again.

Maybe this will work for you. Extract the .bat file from the archive attached to this post to your desktop. When you're experiencing the problem, just double-click the file and it should fix the problem.
 

Attachments

#3
Wow! that was a quick response - thanks - at least I'm not the only one with the problem. I wasn't able to download the zip file as I don't appear to have permission to access it (keeps taking me to a login page even though I'm logged in). Is it possible to paste the .bat code into a reply so I can copy and paste to a .bat file myself to try it. Thanks.
 
#4
i opened it with notepad and this is what i got dont know if its too short:

net stop "Windows Audio"
net start "Windows Audio"

see if it helps
 

mqudsi

Mostly Harmless
Staff member
#5
Wow! that was a quick response - thanks - at least I'm not the only one with the problem. I wasn't able to download the zip file as I don't appear to have permission to access it (keeps taking me to a login page even though I'm logged in). Is it possible to paste the .bat code into a reply so I can copy and paste to a .bat file myself to try it. Thanks.
Check the "remain logged in" option.
 
#6
here's a major twist....

... well, strangely my mobo (bought this january) died yesterday! Don't think it had anything to do with the problem though.

So here's what I had and what I've got now, which someone might find of interest as it kinda narrows down the problem a bit. When the mobo (or it could be the cpu I suppose) fried I switched to a spare pc I had and connected that in its place.

I had an AM2 5200 on a Gigabyte GA-MA69G-S3H with vista sp1. I used any of PowerDVD 8, Cool DVD, DIVX player.

The spare is an Intel E6300 dual core on an Asrock Dual VSTA mobo with XP Pro and only Crystal Player.

I only moved the ATI 2400XT card across and installed the Realtek 1.89 AC3 drivers and the ATI latest drivers. So no Vista and no faulty mobo/cpu but still had the same sound problems.

This means that its not a Vista problem, it rules out the AMD cpu and mobo, the software players and also the HDDs on the duff machine.

Which only really leaves the ATI card or graphics drivers (I didn't have the Realtek drivers when I first got this problem).

Superb sound when I first boot but after playing one file the next one has a ringing tone to it which is only cured by a reboot (sorry guys but the batch file didn't help - thanks anyway).

Because of the failed pc I'm looking to put together a different combination using an alternate graphics card and hoping that the problem will be solved. Anyone have any recommendations that they know work?

Thanks