help booting the service recovery hidden partition

#1
hi,
i've recently bought an acer 3810T and it had the service partition PQSERVICE (hidden) and the vista home pro partition.
I made a backup of the hidden partition, the service restore disks, then i installed linux ubuntu.
After that all was working, i had my grub with 2 vista entries, the first one made the recovery utility in the hidden partition run, the second one was actually vista.
Trying to fix a linux bug i erased all the disk.
I copied the service partition again from the image i had, but it wasn't booting, So i recovered the vista installation through the service disks i made, but the service partition wasn't booting.
I installed linux again, the grub saw the 2 vista partition like pre-erasing but guess what? The hidden partition wasn't booting neither from the grub entry.
So i think that the image i made is missing something to boot.
I can unhide the partition, assign a drive letter to it and browse.
doing bootsect /nt60 (/mbr) doesn't change anything.
Can easy bcd help me?
I guess so cos i copied all the files from the hidden partition in an external drive and clicking here and there( i don't remember properly what i did) i managed to boot the external hard drive as it was my hidden partition.
please help.

thanks.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Luggio, welcome to NST.
Many OEM PCs which have a recovery partition access it my modifying the MBR to access their own boot routine, which contains an OEM recovery option.
If you install Ubuntu without using the "advanced" button on the grub installation screen, and instructing the setup program to put grub in the Linux partition, the default action is to install grub to the MBR and let it take over your boot completely.
You no longer have the OEM's special boot routines to let you access their recovery partition.
If you made a portable backup of the recovery partition ( the recovery options normally include a "burn a copy to CD" ) when you first used the PC, you should be able to boot it and do a factory reset of the PC. Then when you install ubuntu next time, don't let it take over your boot.

If you made a non-bootable copy of your recovery partition using a 3rd party imaging app, instead of the OEM's own routines, then you could contact Acer for a set of bootable recovery media for which they'll make a charge if you failed to make your own free copy when you had the chance.

You could see if the information here helps at all.
 
Last edited:
#3
thanks for welcome & answer.
Unfortunately i'm from italy and my english isn't so good.
I'll try to explain as clear as possible
I think the only thing i need is to restore the partition boot record.
To confirm that i moved all the files from the service partition to an external drive and i made it bootable with easy bcd(i guess, cos i don't remeber exactly everything).
Now i have the service utility running from the external hard drive.

The problem is: how to make a partition bootable modifying its partition boot record?

regarding the link you sent me, i already knew but it's not working. I assume the alt+f10 recovery option is bios based and make the partition 0:0 run(sry again for my english)
 

Terry60

Knows where his towel is.
Staff member
#4
Can you post the contents of the grub menu.lst so I can see what it's trying to do.

(your english is fine by the way)
 
#5
solved!
i used a software( i dunno if i can post its name) with a restore partition boot record feature or something like that.
It would be useful to know how to do without this software. thank you for your time
 
#6
Glad you got it working (and you're free to post the name of the program that helped, btw). :smile:
If the problem was the partition boot record, then you probably could have fixed it with

Code:
bootsect /nt60 X:
from EasyBCD's Power Console (on the "Useful Utilities" page), where X is replaced with the correct drive letter of the recovery partition.
 
#7
the program is Paragon Hard Disk Manager 2009 Professional

bootsect /nt60 did not work
bootrec neither
i was almost desperate, 3 days of fighting against the acer partition.
i tried almost everything before the discovery of hard disk manager.
hope it can help someone
 
#8
Re:

no need to be panic Just use any good partition recovery tool or Stellar Phoenix Partition Recovery Software which can help you and solve your problem.gud luck