help "bootmgr is missing" no operating system to choose from

#1
First of all, here's the url for a visual presentation of my problem:

http://www.youtube.com/watch?v=RgzBcRA3vMc

So I burned the iso image I downloaded from your website and used the cd to boot on the computer, but then, no operating system shows up on the menu. I ignored it and moved on and tried to do all the rest, but nothing changed. Need some help asap. It's been a week since this problem occured and I'm getting tired of walking everyday to the library to use a computer. :/
 

JustinW

Super Moderator
Staff member
#2
Sometimes clicking next when no OS is displayed well repair it enough so when you try again it'll show up in the list.

If its still not working run chkdsk from the command prompt and try startup repair again:
chkdsk c: /r

We also have manual recovery instructions you can follow.
 

JustinW

Super Moderator
Staff member
#4
Yeah, looks like the wikis down again.

Can you post the problem details you're getting when you try startup repair?
 

JustinW

Super Moderator
Staff member
#6
Is that a video you uploaded?

Edit: yearh, says ken in the username.

Yeah, hopefully it'll tell us whats up. Usually when this type of thing happens somethings wrong with the hard drive.
 
#7
Okay. I just found out that the hard disk is the main problem. Here are the details:

After I clicked Startup Repair, I scrolled down to see the info:

Problem Event Name: Startup RepairV2
Problem Signature01: SystemDisk
02: 6.0.6001.18000.0.0.0.0
03: 0
04: 65537
05: unknown
06: No Hard Drive
07: 0
08: 0
09: unknown
10: 1168

OS Verison: 6.0.6001.2.1.0.256.1
Locale ID: 1033

*other steps continued on next post*

Addendum:

Startup Repair diagnosis and repair log
-------------------------------------------------
number of repair attempts: 1

session details
-------------------------------------------------
system disk =
windows directory =
AutoChkRun = 0
number of root causes = 1

Test Performed
-------------------------------------------------
name: check for updates
result: completed successfully
error code: 0x0
time taken: 15ms

name: system disk test
result: completed successfully
error code: 0x0
time taken: 16ms

Root Cause Found:
------------------------------------------------
a hard disk could not be found. If a hard disk is installed, it is not responding.
 
Last edited:

JustinW

Super Moderator
Staff member
#8
Hmmm... no hard disk. Does it show up in your BIOS? Try reconnecting the data/power cables to the hard drive (with the system off of course).

chkdsk failed... what error did it return?

Do "dir c:" at the command prompt? Is it able to list folders/files, like Windows, Users, Program Files, etc?

Time to get a Ubuntu disc and rescue your data.
 
#9
When was the last time that your computer booted fine?
What have you done since that time that resulted in no hard disk being found, and bootmgr missing?

Those are the two questions that are most likely going to help you solve your problem.
 
#10
Coolname: the last time my computer worked was about a week ago.

My sisters were watching an anime when the computer suddenly shut down.

To Kairo: the hard drive does show up in the BIOS menu. I'm on a school computer now, so I'll find out the answers to your other questions later.
 
#11
Hmm...I bet you got a virus which deleted your bootmgr, and caused your computer to shut down.
No telling what else it messed with. Possibly your MBR got trashed.

Try running these two commands from the Command Prompt:

bootrec /fixmbr
bootrec /fixboot
Then try startup repair again.
 
#13
coolname, the commands doesn't work at all. (see youtube url on the 1st post)
I did watch that video when I first discovered your thread, but I didn't watch all of it. I thought all it showed was you running Startup Repair. I just watched it again, and now I see you running the commands in the Command Prompt, and getting the "The device is not ready" message. Interesting...

Quick question:
Do you have any other HDDs connected to your system? If so, remove them, and try the commands + startup repair again.
 

Terry60

Knows where his towel is.
Staff member
#15
If it's a desktop tower, take off the left side panel and disconnect/reconnect everything attached to the HDDs several times to clean up the contacts. (with the system powered down of course)
If it's a laptop, eject and replace the HDD several times. (ditto)
 

JustinW

Super Moderator
Staff member
#16
There should be two cables attached to the drive, one for data and the other for power. If you're not sure you'll know if its the hard drive if it looks like a disc drive with nothing on the front. Disconnect both cables and reconnect them several times. Make sure they are fully connected before you close the case again.
 

Terry60

Knows where his towel is.
Staff member
#18
check the other end of the cable at the mobo end. dis/reconnect that too.
Is the HDD spinning ? If not try a different power connector.
 

JustinW

Super Moderator
Staff member
#20
Worked once as in you were able to boot Windows???

You might have faulty cabling... try reconnecting a few more times.