Help, dual boot won't work.

#1
Hi,

Hope some1 can help, I have windows XP installed on a RAID 0 and Vista installed on a single drive. Both work however i have to change the boot from different HDDs in the bios in order to boot into each.

I dont get it, but i thought vista would automatically put a dual boot option in for you when you install, but it didn't so i downloaded EasyBCD.

I tried adding an entry for XP in easybcd, but it doesn't work, when i try and select the new XP line i input into the dual boot menu, it just goes to a black screen and restarts the PC. Vista loads fine if i select that though.

How can i get it to boot into XP on my RAID 0 also?

Cheers,

Paul
 

mqudsi

Mostly Harmless
Staff member
#2
set vista to boot drive.
add xp entry in easybcd.
copy boot.ini and ntldr and ntdetect from XP's drive to Vista's.

Modify boot.ini (on vista's drive) to point to the correct XP drive numbers [probably disk(0)rdisk(1)partition(1)]
 
#3
Help again...

Hi there computer guru,

You helped me on this before and I forgot to post a thank you reply so apologies for that, but I was extremely grateful.

Thing is I managed to screw up vista 64 so bad that it would no longer emulate/run 32bit applications, this was achieved by installing the SCSI thingy that comes with daemon tools, but nevermind about that as I have re-installed vista.

In doing this I obviously lost my dual boot setup that you ever so kindly helped me with. Trouble is I followed your settings once again, but alas...it doesn't seems to work, it just restarts when selecting XP again. Where am I going wrong? I created the entry in BCD, (c:\ as is vista), copied boot.ini-ntldr-ntdetect from XP's drive to the vista one, and finally edited the boot.ini on the vista drive to your suggested values (I have tried a few other too, but no luck).

Please can you help again, I promise to leave a thank you note this time...:smile:

Thanks

Paul
 
#5
Thanks!!

HI Computer Guru, here is the promised thank you reply.

It wasn't actually the boot.ini at fault, I tried the two combinations of rdisk of 0 or 1 that it could be but it didn't work (I don't have any HDD partitioned and I only have the RAID XP HDD/s and vista HDD in there), so I thought there must be something wrong with NTDETECT or ntldr so I copied them over again. Low and behold it worked straight away with rdisk 1 like last time. Must have been corrupt ntdetect/ntldr of some description!?

Many Thanks for your prompt reply though and for your help before, couldn't have done this without you! :smile:

Paul
 

mqudsi

Mostly Harmless
Staff member
#6
You're welcome :smile:

Glad it's working now.