Help on Dual boot Windows 7/Ubuntu 10.04 Using Windows Bootloader

#1
Hi, I'm new here and am also new to dual booting. I have searched google and this forum for an answer to my problem but I can't seem to find it. (I'm also a noob in Ubuntu so please bear with me)

So here's my setup:
Disk C: Windows 7 64-bit (160gb)
Disk D, Partition 1: Ubuntu 10.04 64-bit (15gb)
Disk D, Partition 2: Swap (5gb)
Disk D, Partition 3: NTSF partition for files (480gb)

Windows was installed first, followed by Ubuntu. So after that I have no problem switching between Windows 7 and Ubuntu using GRUB. But GRUB is too cluttered so I want to use the Windows bootloader instead.

I use EasyBCD and these are the settings I create:

There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Ubuntu 10.04
BCD ID: {06925947-9863-11df-860e-d761e5c6493d}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr
So whenever I get to the bootloader, I can boot into Windows 7 just fine. But when I try to boot Ubuntu, it gives me an Startup error which points out that the path \NST\AutoNeoGrub0.mbr is missing. So I did some stuff like install the NeoGrub in the add entry menu and tried switching the drive to D:\ but to no avail. Now I can't boot into Ubuntu, unless I re-install it (which I did), but then I tried using Windows bootloader again, but still nothing.

So please, any help would be greatly appreciated. Thank you!
 
Last edited:

pepar

New Member
#2
Yeah, me too EXACTLY! Linux (Mint 9) evidently isn't EasyBCD-aware and hosed my bootloader. I re-imaged Win 7 on drive 0, C:/, and added an entry for Linux in EasyBCD but that didn't work at all. I deleted it and added another but set to "automatic." That also didn't work, but at least got me into a list of choices that looked like possible file locations.
 

mqudsi

Mostly Harmless
Staff member
#3
Hi RapboY and pepar, welcome to NST.

Are you guys using EasyBCD 2.0?
 

pepar

New Member
#4
Hi RapboY and pepar, welcome to NST.

Are you guys using EasyBCD 2.0?
Yes.

I'm thinking that since Win 7 doesn't see the ext4 drive - it's in Disk Manager but w/o a drive letter - EasyBCD is not pointing to it correctly. Here is a screencap of my entries. Linux is *not* on C:\ BTW.

Thanks,
Jeff

 
Last edited:

pepar

New Member
#10
Well, hopefully the grown-ups will show up soon and help us tumbling toddlers!

Jeff

Addendum:

yep checked that already and tried doing what i was able to understand out of it.. but no luck..
Gonna try this tonight. I have an image of my Win 7 install, so I can always fix any mess that I make.

Jeff
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#11
You can try this:

Delete the Linux entries in EasyBCD. Replace C:\Program Files\NeoSmart Technologies\EasyBCD\profiles\GRLDR with the attached.

Create a new Linux entry in EasyBCD, selecting "GRUB2" from the drop-down.
 

Attachments

mqudsi

Mostly Harmless
Staff member
#13
Thanks. Did that work?

I'm going to be turning in soon... middle of the night here :smile:
 

pepar

New Member
#14
Thanks. Did that work?
Won't know until I get home from work and try it. :??

Almost 5PM here. Time for happy hour.

Addendum:

You can try this:

Delete the Linux entries in EasyBCD. Replace C:\Program Files\NeoSmart Technologies\EasyBCD\profiles\GRLDR with the attached.

Create a new Linux entry in EasyBCD, selecting "GRUB2" from the drop-down.
That took me to the GRUB4DOS command line.

Jeff
 
Last edited:
#15
hey! it worked! what file was that anyway?

jeff sorry to hear yours is still not working.. mine brings me right to the grub menu..

guru is there a way to bring me straight to ubuntu without going through the grub menu? thank you so much! :grinning:
 

mqudsi

Mostly Harmless
Staff member
#16
rapboY: Congrats :smile: Glad that did the trick for you :smile:

Jeff: What version of Ubuntu are we talking about? And did you upgrade from an older version or is it a clean install?
 

pepar

New Member
#17
hey! it worked! what file was that anyway?

jeff sorry to hear yours is still not working.. mine brings me right to the grub menu..

guru is there a way to bring me straight to ubuntu without going through the grub menu? thank you so much! :grinning:
Mine *is* working, but it's "working" like yours is!

Jeff
 

mqudsi

Mostly Harmless
Staff member
#18
Jeff, he means that gets a GRUB menu with a list of entries in it to choose from.

If I understood you correctly, *You* get a grub command line.
 
#19
run the the terminal.and then type the command below:
sudo chmod +w /boot/grub/grub.cfg
# make the Ubuntu grub.cfg for you to edit it.It is used for configueing the boot prosess
sudo gedit /boot/grub/grub.cfg
#use gedit to edit it .you can use other editor if you like.
#then you just find the " timeout=10" out, And change it into "timeout=0"
#that will make you boot into Ubuntu without the grub2 selecting list

all above is my setting in win7 and Ubuntu 10.04

Hope it can help you
 

mqudsi

Mostly Harmless
Staff member
#20
Hi VIVXIX, welcome to NeoSmart Technologies.

Thanks for sharing the steps to make the Ubuntu menu go away :smile: