Help removing partition

Coolname007

Distinguished Member
Error 12: Invalid device requested

Press any key to continue...

If you got that error when trying to follow the same sort of config Win 7 is in your menu.lst for OS X, I don't think that will work...:wink: OS X would probably use a different configuration, if it works with Grub at all. Let me do a little Googling, and see if I come up with anything in regards to getting OS X to boot directly from Grub...

-Coolname007

Addendum:

Ok, I found something...:smile:
The advice that I found says this config may work:

Code:
title Mac OS X  
rootnoverify (hd0,4) 
makeactive  
chainloader +1
Test it out, and see if it does.

-Coolname007

EDIT: If that doesn't work, then try the following instructions:

1) Copy the folder "i386" from the OSx cd (which is located at /usr/standalone/i386)and put it in /boot/grub/ The i386 folder is hidden normally so ensure you can see all hidden files in whatever operating system you are currently in. What I did is copied the files over in windows to a flash drive and then copied them from the flash drive to my home space and then used the following command in the terminal: cp -r /home/i386 /boot/grub/i386
2) Go To Applications > System > YaST
3) Go To "System" and select "Boot Loader"
4) Click "Add"
5) Select "Other System (Chainloader)"
6) Type in OSx86 for your Section Name and for Device select browse.
7) Browse to where you saved your i386 folder and select the chain0 file. This means you should have /boot/grub/i386/chain0 in the field where it says device
8) Click OK and you're done.
NOTE: If you try editing the menu.list file straight, it will not show OSx as a choice. You must initially use Yast in order to get the option to show in GRUB then if you desire you can edit it manually. .
 
Last edited:

hdjunkie

Active Member
Ok, will do...this could take awhile.

Addendum:

There doesn't seem to be an i386 folder on the ideneb dvd.
 
Last edited:

Coolname007

Distinguished Member
There doesn't seem to be an i386 folder on the ideneb dvd.

hmm...is it a 64-bit version of OS X on the DVD then? :wink: And did you make sure to unhide all the files first? Where are you mounting the DVD from? From Windows or Ubuntu?

-Coolname007
 
Last edited:

hdjunkie

Active Member
No, the DVD is named "Layne OSx86 DVD" and I booted it from windows. here's what the folder looks like.
 

Coolname007

Distinguished Member
Ok...so try going to Folder Options in the Control Panel in Win 7, selecting the View tab, and placing the radio button in the "Show hidden files and folders" option under "Hidden files and folders", and then unchecking the box called "Hide protected system files." :wink: This will reveal all of your hidden files, and hidden system files, and you should be able to see the folder then. FYI, the folder is located at /usr/standalone/i386.

-Coolname007
 

Coolname007

Distinguished Member
There it is! I searched, and I thought I looked through all the folders but it's right where you say it should be.

Ok...so now copy it onto a flash drive or something, reboot into Ubuntu, plug in the external device and paste into /boot/grub on the Ubuntu partition, and then follow the rest of the steps [post=33262]in this post[/post] minus the command of course, since all that does is copy it into the same location from /home. :wink:

-Coolname007
 
Last edited:

hdjunkie

Active Member
Edit: I decided to go to gparted, and wipe everything out. I now have 3 primary partitions (hd0,0 ubuntu ext3 hd0,1 windows ntfs, hd0,2 osx fat32). for each os and an extended partition for the swap. I'm hoping osx will be fixed after re-installing everything by being on a primary partition. We'll see... (4:28 am)

I just had my first successful boot without the osx dvd. It seems having it on a primary partition was the solution. Even updates work. (5:16 am)

Success!!! After loading ubuntu I simply added the osx option to grub and it works!!!
 
Last edited:

Coolname007

Distinguished Member
Edit: I decided to go to gparted, and wipe everything out. I now have 3 primary partitions (hd0,0 ubuntu ext3 hd0,1 windows ntfs, hd0,2 osx fat32). for each os and an extended partition for the swap. I'm hoping osx will be fixed after re-installing everything by being on a primary partition. We'll see... (4:28 am)

I just had my first successful boot without the osx dvd. It seems having it on a primary partition was the solution. Even updates work. (5:16 am)

Success!!! After loading ubuntu I simply added the osx option to grub and it works!!!

Glad to hear it. :smile: I would have thought Apple would have been smart enough to create their OS so it could boot off of logical partitions, but I guess I was wrong...oh well. :wink: Glad everything turned out for you. Let us know if you have any more problems.

-Coolname007
 

JustinW

Super Moderator
Staff member
Yay :smile:

Yeah. I like all primaries myself if I can manage it. My system was set up with a extended partition as well. Had messed up my system one time and used Acronis ability on restore to convert them all to primaries. Makes things a heck a lot simpler.
 
Top