HELP - Ubuntu not working with quad boot

#1
I have successfully triple booted Vista, XP, and Mac OS X on my pc and today I installed Ubuntu as a fourth operating system. The grub bootloader overwrote the vista bootloader so I had to do a fixboot to bring it back and I had to redo my bcd entries. I had some trouble getting XP to boot but after some fiddling around I eventually rebuilt the boot.ini file and it was up and running again. OS X is a breeze thanks to easybcd 2.0 beta.

Anyway, my problem is now getting Ubuntu to boot. I added it to the BCD, but when I select it in the bootloader I just get a blank black screen, no error messages or anything. I even tried pointing the boot sector to every single partition that I have on this PC and all give the same result - a black screen.

Heres what my bcd looks like:

There are a total of 4 entries listed in the bootloader.

Default: Windows Vista (TM) Ultimate
Timeout: 2 seconds.
Boot Drive: E:\

Entry #1
Name: Windows Vista (TM) Ultimate
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Microsoft Windows XP Professional
BCD ID: {ed027b5d-b16a-11de-90eb-d66f34ec1eb2}
Drive: C:\
Bootloader Path: \NTLDR

Entry #3
Name: Ubuntu Linux
BCD ID: {ed027b6b-b16a-11de-90eb-d66f34ec1eb2}
Drive: E:\
Bootloader Path: \NST\nst_.mbr

Entry #4
Name: Mac OS X Leopard 10.5.6
BCD ID: {ed027b6c-b16a-11de-90eb-d66f34ec1eb2}
Drive: E:\
Bootloader Path: \NST\NeoGrub.mbr


This is detailed (debug mode):

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=E:
path \bootmgr
description Windows Boot Manager
default {ed027b5b-b16a-11de-90eb-d66f34ec1eb2}
displayorder {ed027b5b-b16a-11de-90eb-d66f34ec1eb2}
{ed027b5d-b16a-11de-90eb-d66f34ec1eb2}
{ed027b6b-b16a-11de-90eb-d66f34ec1eb2}
{ed027b6c-b16a-11de-90eb-d66f34ec1eb2}
timeout 2
resume No

Windows Boot Loader
-------------------
identifier {ed027b5b-b16a-11de-90eb-d66f34ec1eb2}
device partition=C:
path \Windows\system32\winload.exe
description Windows Vista (TM) Ultimate
osdevice partition=C:
systemroot \Windows
resumeobject {204baf75-b167-11de-bb8e-806e6f6e6963}

Real-mode Boot Sector
---------------------
identifier {ed027b5d-b16a-11de-90eb-d66f34ec1eb2}
device partition=C:
path \NTLDR
description Microsoft Windows XP Professional

Real-mode Boot Sector
---------------------
identifier {ed027b6b-b16a-11de-90eb-d66f34ec1eb2}
device partition=E:
path \NST\nst_.mbr
description Ubuntu Linux

Real-mode Boot Sector
---------------------
identifier {ed027b6c-b16a-11de-90eb-d66f34ec1eb2}
device partition=E:
path \NST\NeoGrub.mbr
description Mac OS X Leopard 10.5.6



I have 3 hard drives, and Ubuntu is installed on Drive 2, Partition 2 (the third drive, first being drive 0).

Anyone know why I'm getting this black screen and no grub? Ubuntu was loading fine with the grub bootloader... Thanks in advance!

Addendum:

To add, I just reinstalled Ubuntu following the exact steps given here:

Ubuntu - NeoSmart Technologies Wiki

and I am still getting the blank black screen. This is getting very frustrating...
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi unkel, welcome to NST.
You appear to have rebuilt your Vista boot in the wrong place.
The boot drive ("system" in MSese) appears to be E not C (Vista), but XP's NTLDR entry is not pointing there, so I'm not sure how that's working.
You have OSX pointing there and using Neogrub, and Ubuntu pointing there and not using Neogrub.
Can you post a .jpg screenshot of Vista Disk Management (use the paperclip in "Go Advanced") so we can see the configuration properly.
If Ubuntu is on a different disk to the Vista bootmgr, you'll need to use Neogrub to bridge (tick the "grub isn't.....) box. Unfortunately if OSX is already using Neogrub, then the Ubuntu entry will overwrite the OSX info in the Neogrub menu.lst (unless this is something CG has changed in later builds of 2.0)
What you'll need to do (this advice is coming from someone who doesn't use OSX, though I do quad-boot, so treat it as advice not holy-writ),
is first, make sure that "system" is where you really want it to be,
second, use Easy2 to add an XP entry (let it auto-configure),
and third, merge the information from the OSX and Ubuntu Neogrub into a single menu.lst which gives you a secondary menu to choose between them.
 
Last edited:
#3
Hi Terry,

Here is my drive setup:




I also found this thread that describes the same problem I'm having:

Blank screen booting Linux - The NeoSmart Forums

It doesn't seem to have been resolved but it may provide more insight into the problem than I can.

I copied all of my boot files to C:\ E:\ and F:\ because I dodn't know any better and it got my XP to boot.

This is what my neogrub menu.lst looks like:

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at E:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# EasyBCD Documentation Home - NeoSmart Technologies Wiki


find --set-root --ignore-floppies /NST/nst_mac.efi
kernel /NST/nst_mac.efi
boot

# All your boot are belong to NeoSmart!


# All your boot are belong to NeoSmart!
find --set-root --ignore-floppies /boot/grub/menu.lst
configfile /boot/grub/menu.lst

# All your boot are belong to NeoSmart!



How would I add Ubuntu to this list? When I installed Ubuntu I had it install the bootloader on the ubuntu partition like the tutorial instructed. Thanks for your help!