Help!!! - Urgent Problem

myden

New Member
The original condition of my system :

1. HP media center PC
2. Windows Vista SP2
3. 2 Partitions:
C: - Vista system
D: - HP recovery partition

What I did:

1. I shrinked out 60G from C partition
2. I installed Fedora 14 to this 60G space. I installed fedora's boot loader on this new partition. I just don't want to mess up windows boot loader.
3. I installed easybcd on vista
4. I added a new entry for Fedora named Fedora, however I chose the Grub 2 option, it won't work after reboot.
5. I deleted this new entry from easybcd.
6. I added the othe new entry for Fedora named Fedora. This time I chose the Grub leagcy option.
7. Reboot. The oddest thing happened. Boot menu shows two Fedora menu. Vista is gone.
8. I tried the first one. It won't wok.
9. I tried the second one. It can boot into Fedora.

How I tried to fix it:

1. I used F11 to go into recovery manager
2. I chose repair tool to repair it
3. Reboot. The two Fedora boot menus are still there.
4. Press F11 again. The other odd thing happened. I booted into Vista which I was never expected.
5. I runned easybcd in vista. I can't find those two Fedora boot menu. There is only one menu in there named Windows Vista (TM) Ultimate (Recovered).
6. I am totally confused with this situation. I added two new entries, one for vista, one for Fedora from easybcd.
7. Reboot. The two Fedora boot menus are still there. Press F11, go into a new windows boot loader menu with three boot menus(Vista, Fedora, Windows Vista (TM) Ultimate (Recovered)).

Help fix it back to normal !!!!!!!!!!!!!!

1. I don't want to lose F11 recovery funcition.
2. Fix the two Fedora boot menus to normal condition. One for Vista, One for Fedora.

Thanks in advance for who can give me a solution to fix it back.

Thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

mqudsi

Mostly Harmless
Staff member
EasyBCD -> Bootloader Setup -> Write MBR
 

myden

New Member
Thanks for the solution

Thanks for the solution. I thought to write MBR through Easybcd. However, I was afraid it will damage the F11 recovery boot function from HP recovery partition. Do you know the reason why I went into vista and can't find the original boot menus(The two fedora boot menus) in Easybcd after pressing F11? In my knowledge, I should see them , not a new boot menu. Is there any chance this solution may cause the other unexpected damages?
 

JustinW

Super Moderator
Staff member
Appears Vista's entry was deleted and you were left with just entries for Fedora. Startup repair to recover the Windows boot loader might have given you a new boot menu. Is Vista booting now? Add a new entry for Fedora and you'll have a new menu to boot either Vista or Fedora. Delete any extra or non working entries.
 
Top