Help with 64 Bit Vista Recovery CD

robbw

New Member
#1
Similar to a lot of others, I'm running into some issues using the recovery disk option. A couple of days ago, I got the blue screen of death and when I re-started, it can't boot Vista, etc. due to hardware, etc. So, I found and downloaded the disc here:

Windows Vista Recovery Disc Download The NeoSmart Files

Successfuly burned it using IMGBurn instructions here:

Burning ISO Images with ImgBurn - NeoSmart Technologies Wiki

When I insert the CD, re-start the computer, I start following the instructions here:

How to automatically repair Windows Vista using Startup Repair

All is well until I get to Figure 4. In this box, Vista is not listed as shown. If I click Load Drivers, a box comes up, but I haven't the foggiest what to pick from here. If I cancel and click Next, and get to the startup repair window like Figure 5, it just searches for problems for days without restarting or anything.

I'm kind of stuck now. Should I really load some drivers? If so, how do I do that? Any other ideas or suggestions?

Thanks,
Robb

[EDIT] Browsing around, I've also read that it takes Vista a couple of times doing this to repair itself. I've tried this a couple of times, but it never fully "gets done" the first time. It nevers tells me that it was successful OR that it couldn't repair it successfully (which would prompt me to boot it over again, based on what I'm reading). The longest I let it try is 42 hours and it stayed on the Figure 5 screen the whole time. I gave up and turned it off. Thought I would throw that in, too.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi Rob, welcome to NST.
Do you have more than one HDD ?
If so, disconnect all of the others temporarily before trying the repair startup.
The recovery CD (and the Vista DVD too) can have trouble finding a broken OS when there's another disk(s) connected, especially if the HDDs are a mix of SATA and IDE.
 

robbw

New Member
#3
Thanks for replying. I believe there are 2 HDD's, but I'm not fully sure because it's a work computer my boss gave me last week for home. When I crack it open tonight, how will I know which HDD to leave connected?
 
#4
I think you will have to try one at a time. If Vista cd is still unable to see the installation, use the command prompt, type :

Diskpart {then press enter}

lis disk {then press enter}

lis vol {then press enter}

exi {then press enter to leave diskpart}

Let us know what it says.
 

robbw

New Member
#5
Well, I just cracked it open and there's only one hard drive. I will try what SIW2 suggests above and let you know.

Addendum:

Got the command prompt open, it has

X:\Sources>

Is this where I start with the Diskpart command?

Addendum:

OK, I got this:

DISKPART> lis disk

Disk ### Status Size Free Dyn Gpt
------------ ------------ -------- -------- ------- ------
Disk 0 Online 69 GB 0 GB

DISKPART>lis vol

Volume ### Ltr Lable Fs Type Size Status Info
---------------- ----- ----------------- -------- ---------------- ---------- -----------
Volume 0 D 2008.03.29_ UDF DVD-ROM 149 GB Healthy
Volume 1 C RAW Partition 69 GB Healthy

DISKPART> exi

Leaving DiskPart...

X:\>
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
If there's only one disk, try booting the recovery CD, but instead of the startup repair, from the same screen open the Command Prompt, and run a chkdsk /f against the Vista partition.
It will run for some time, but it might find and fix bad blocks in the boot sector.
Try the startup repair again after it's finished.
 

robbw

New Member
#7
OK, right now, my prompt says

X:\>

When you say "against" the partition, can I just run the chkdsk /f from this prompt?

Addendum:

Also, I tried changing it to my partition drive (C) by typing in C: at the prompt, but it said "The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted" According to the Diskpart thing, my C drive is healthy. Anyway, thought I'd throw this in there, too.

I can change it to D: though (my dvd rom drive) for what it's worth, but I'm pretty sure I need to get it to the C: to run the chkdsk /f on that.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#8
You need to find what the Recovery Console is calling your partitions. All Windows OSs, including rudimentary ones like the Recovery Console, letter your drives themselves. There's no actual letter on the partition. Vista might not be C: from the command prompt.
Run dir x: commands, varying x= C,D,etc, and it will list the drive directory. You should be able to spot Vista by the contents and use that letter in the chkdsk.
 

robbw

New Member
#9
Thanks for sticking with me. I tried dir x: for a-h (in place of x) and for a, b, e, f, g, & h, it just says "The system cannot find the path specified." For dir c: it still says "The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted" and for dir d: it gives me a boot dir, a sources dir, and a bootmgr file (all this is presumably my CD drive).

It's almost like I still need to upload some type of drivers for my hard drive to make this work. I don't know.
 
#10
Sorry, if it says RAW - that means it is seen as unformatted. It probably still has the ntfs filesystem , but there is a partition table error.

Did you backup the entire first track ( mbr) of the HD using a backup utility ?

Better still - do you have a recent backup image of the drive?

If so, use the bootable disc from the backup software and restore it.

If not - you should be able to recover all the partitions except 1.

I hope you had more than 1 and you can remember roughly their positions and sizes.

Addendum:

You may still be able to undelete the partition if you only had 1 - this has only just come out in bootable form

It is a free downloadable app. ( Partition Wizard)

http://www.partitionwizard.com/download/pwhe41.iso

Burn the .iso to cd. Boot the cd.

If it sees the drive, click Disk 1 near the top of the screen to highlight it and click partition undelete in the left pane.

If that is not successful, you have a couple of options

1. Create a partition and reinstall windows - if you make it much smaller than the drive (16gb is enough) - after reinstalling windows, you can use a file undelete app. and attempt to get back at least something from the remainder of the drive.( Not likely to recover a huge amount)

2. If your data is important - clone the drive to a larger external HD - Partition Wizard has a drive copy function. You may be able to undelete the partition from that later.

If Partition Wizard is not successful - try GParted - also a free .iso download. It does not have a partition undelete tool - but you should be able to copy the drive off with that , and create partition(s) if you wish.

http://sourceforge.net/projects/gpa...ble/0.4.6-1/gparted-live-0.4.6-1.iso/download

When you have done a sector by sector copy to a larger HD - you can create a small partition in the remaining unallocated space - PW undelete partition tool may work then , if it didn't previously.
 
Last edited:
#11
OK, I finally got around to booting up with Partition Wizard. It does recognize the disk, but it has "Bad Disk" under the File System column.

The "Partition Operations" on the left hand side has the following options. I don't see a partition undelete here. Only these:

Create Partition
Format Partition
Delete Partition
Move/Resize Partition
Copy Partition
Set Label
Explore Partition
Wipe Partition

Under "Disk Operations" I have these:
Delte All Partitions
Copy Disk
Partition Recovery
Wipe Disk

Help! Thanks.

Robb
 
#13
Yep, Click Disk 1 to highlight it and select Partition Recovery.

Try Scan Full Disk, Next. Quick scan , Next.
 
Last edited:
#15
Does it allow to create a partition?

If so you are going to have to create a partition the size of the entire drive - select ntfs. Then delete it. then try partition recovery.

It sounds like there may be something wrong with the drive - not just a partition table error.

If PW doesn't allow any operations - you could try one more thing:

D/L GParted - burn to cd - see if that is able to create a partition the size of the entire drive.

http://sourceforge.net/projects/gparted/files/gparted-live-stable/0.4.6-1/gparted-live-0.4.6-1.iso/download

Then boot PW again , delete the partition and try partition recovery.

If neither PW nor Gparted allow any operations - you are out of luck.
 
#17
Well, it looks like I'm out of luck. GParted cannot even detect a device and therefore, I cannot create a partition, etc. Looks like a new hard drive for me. Thanks again for helping me try.

Robb