Help with EasyBCD 1.7.2

#1
Hi,

I am new to this program and need some help to accomplish what I need to do.

Problem :

When I am booting up Vista Ultimate, the Boot Mgr comes up and shows me one entry :

"Windows Vista"

and I have to hit ENTER to continue. I don't do dual boot or anything like that, so what do I have to do in EasyBCD in order to remove the boot manager entry of Vista and have Vista started automatically as soon as I entered my Bios password ?

So far, I installed EasyBCD but have not done anything; I'd like to wait for an answer to this post.

Thank you,

Cheers,

JCE
 

Terry60

Knows where his towel is.
Staff member
#2
Hi JCE, welcome to NST.
You shouldn't see a menu normally unless there's a choice to be made, so you must have a phantom entry.
Open EasyBCD "view settings" and you should see if there's a spurious entry which you can remove in the "add/remove entries" tab.
If you're not sure which is the correct entry to remove, an alternative approach would be to set the timeout value to 0 in "change settings". This will suppress the display of the menu and will take the default choice.
Does Vista boot OK if you just wait (don't hit enter) at boot time ?
If so, then the default choice is the right one, and timeout=0 will be an effective way to stop the menu displaying.
If the default doesn't result in a successful boot, then you'll need to remove the duff entry (which will be the one listed as default in the "change settings" tab)
If the default choice does boot OK then you'll know that the other one in the dropdown menu of "change settings" (default), is the one to remove, if you want to do it that way.


Sorry if that all sounds very confusing, offering different ways to achieve the same result, hope you understood. Post back if I've made it unclear.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#3
Just post the contents of EasyBCD's "detailed mode" here in a reply and we'll guide you through the steps to fix your problem :smile:
 
#4
Hi,

thanks to both of you for the reply.

What I have done so far is, to set the "Timeout to 0". At boot, the menu is now still visible, but only for 1/2 second.
I would like to configure it in such a way, that there is no menu coming up at all and Vista is just loading by it self at startup.

Here is the EasyBCD "DETAILED" mode :

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
path \bootmgr
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {afd5abaf-f2ee-11dd-809d-002185f0a29e}
displayorder {afd5abae-f2ee-11dd-809d-002185f0a29e}
{afd5abaf-f2ee-11dd-809d-002185f0a29e}
timeout 0
Real-mode Boot Sector
---------------------
identifier {afd5abae-f2ee-11dd-809d-002185f0a29e}
device partition=C:
path \NTLDR
description Microsoft Windows
Windows Boot Loader
-------------------
identifier {afd5abaf-f2ee-11dd-809d-002185f0a29e}
device partition=C:
path \Windows\system32\winload.exe
description Windows Vista (TM) Ultimate (recovered)
osdevice partition=C:
systemroot \Windows
resumeobject {f92c04a8-f2ef-11dd-bb40-806e6f6e6963}

Thank you so much for helping.

Later,

JCE
 

Terry60

Knows where his towel is.
Staff member
#5
Leave the Windows Vista Ultimate (recovered) entry alone and delete the other one (half an XP entry from who knows where) in "add/remove entries"
 
Last edited:
#6
Hi,

wow, super fast reply !! :smile:

Well, I deleted the entry you suggested rebooted. Now I am getting the menu again. It stays there until I hit "Enter" even with the time out at "0" !

Here are the new EasyBCD details :

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
path \bootmgr
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {afd5abaf-f2ee-11dd-809d-002185f0a29e}
displayorder {afd5abaf-f2ee-11dd-809d-002185f0a29e}
timeout 0
Windows Boot Loader
-------------------
identifier {afd5abaf-f2ee-11dd-809d-002185f0a29e}
device partition=C:
path \Windows\system32\winload.exe
description Windows Vista (TM) Ultimate (recovered)
osdevice partition=C:
systemroot \Windows
resumeobject {f92c04a8-f2ef-11dd-bb40-806e6f6e6963}

What can I try next ?

Thanks again,

JCE
 

Terry60

Knows where his towel is.
Staff member
#7
I'd suggest adding a new entry for Vista (add/remove again) and making it the default with a name you recognize it by and timeout=5 (all in change settings) to give you a chance to select the old entry if necessary.
Boot and wait 5 seconds.
If it goes to Vista OK delete the previous entry and leave just the new one.
 
#8
Hi,

I did all that and now I ONLY have ONE entry ( see details below ), but at reboot, the Boot Mgr. comes up with "choose...." and shows me :

Windows Visa

But even with the Time Out at 5, it just sits there and waits until I hit ENTER............ So, I still get the boot manager coming up.

Details :

There is one entry in the Vista Bootloader.
Bootloader Timeout: 5 seconds.
Default OS: Windows Vista
Entry #1
Name: Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

What can I do to get rid of this boot manager window and have Vista start automatically at boot, without either the boot mgr. sitting there or the boot mgr flickering up ?

Thanks,

JCE
 

mqudsi

Mostly Harmless
Staff member
#9
OK, time to fire the main cannons.

EasyBCD | Diagnostics Center | Reset BCD Storage
 

JustinW

Super Moderator
Staff member
#10
Enter at the command prompt:

Code:
bcdedit /set {bootmgr} displaybootmenu no
Should make the menu go away...
 
#11
Hi,

Cool !!!! Thanks, that worked !! Now everything is like I wanted it !!!

Again, a big THANKS to ALL of you for helping.

Cheers,

JCE
 

mqudsi

Mostly Harmless
Staff member
#12
Great knowing everything is well again in the world of bootmenus and bootloaders.

Which approach did you use?
 
#13
Hi,

after creating a new entry with EasyBCD and deleting the old one , the last thing I did to make it work was the command line :

bcdedit /set {bootmgr} displaybootmenu no

Now, no bootmanager is showing up at all and the boot is automatic.

Thanks again to all of you,

JCE
 

JustinW

Super Moderator
Staff member
#14
Hey glad everythings fine now :smile:

Now word of warning. If you ever want to install a second OS in a dual-boot, you'll need to run the command again with yes instead of no. Even with multiple entries if that is set to no it won't show and boot the default, regardless of the timeout.
 
#15
Hi,

thanks for the warning. I made myself a note ! But usually I don't need Dual Boot, I rarely need another OS, if I do, I run it on a Virtual Machine !

Thanks again,

JCE