How do I edit the Boot info


I have Vista on one drive and XP on another.

I have added an entry for XP and when I try to boot to Xp the system simply re-boots.

This is what the boot config shows:

There are a total of 2 entries listed in the Vista Bootloader.
Bootloader TimeOut: 30 seconds.
Default OS: Microsoft Windows Vista

Entry #1

Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Microsoft Windows
BCD ID: {99fe61f1-b6d9-11db-aeac-8000600fe800}
Drive: E:\
Bootloader Path: \ntldr
Windows Directory:

As you see, the Windows Directory for Xp is missing.

When I first added the entry although I put E: in the drive box, Easybcd saved it as C: and caused \ntldr missing errors, so I changed it to E: manually. Then it started to re-boot on choosing the XP boot option

Is this what causes the problem with the XP choice re-booting?

I have tried to add the \Windows directory to the config, but can't see where to add it.
If I go into debug mode in the settings window, there is no entry headed Windows directory for the XP details.
Hi pewe, welcome to NST.

You need to create/edit a boot.ini file and place it in the appropriate drive.

XP shouldn't go to drive E: usually, it defaults to the drive with the BOOT folder - and if the Vista Bootloader is properly configured, that's where XP should boot from.
Thanks Guru.

So I change the config back to C: as Easybcd set it originally??

I already have the boot.ini on the E: drive which reads

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

So I can copy this to the Vista drive??

If so, what changes do I make - ie the 'disc' is not the same anymore so what should I change this to. Its not very clear from the page you referred to.
Change the disk number and the partition number to match your new configuration. both start counting at zero. then add the /usenewloader to the entry in boot.ini, THEN copy it over. rdisk should remain 0.
Thanks Guru.

I copied the boot.ini to the Vista drive and it now looks like this

[boot loader]
[operating systems]
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect /usenewloader

But when I try to boot XP it still says it can't find ntldr

Status 0xc000000F.

Should I have copied the ntldr across to C: too?