How do I remove Windows XP setup from boot manager?

Jace

New Member
#1
Hello, I recently did a fresh install of Windows 7 on my XP machine. Whenever my computer boots up, it goes to the boot manager and displays 'Windows 7' and 'Microsoft Windows XP Professional Setup' as the two options, with the latter being the default option. When it boots to Setup it obviously gives errors followed by rebooting my system and I no longer have an XP setup disc to reinstall XP.
Per a previous suggestion I've looked through the hard drive with all hidden file options properly set to find boot.ini to delete it but it doesn't exist..I was able to find boot.bak and delete it though. I've included images of the EasyBCD entries screen, the disk management and the bootloader text. Any help is much appreciated.
Thank you!

There is one entry in the Windows Vista bootloader.

Default: Windows 7
Timeout: 30 seconds.
Boot Drive: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
EasyBCD /Tools / Edit legacy entries should find boot.ini for you.
 

phugu

New Member
#3
Same XP Boot Problem

I'm having the same problem as Jace. I've already tried the EasyBCD route, as well as BCDedit.

I've even looked into using bootcfg, which shows there is only one option (XP Setup) that I can't delete.

I'd be grateful for any further suggestions.

Phugu
 

mqudsi

Mostly Harmless
Staff member
#6
EasyBCD 2.0 should work.
 
#7
Sorry, but EasyBCD does not work. Any other suggestions?

Hi Guru,

I am having the same problem as the others in this thread, but can personally attest to the fact that EasyBCD 2.0 does not solve it, nor does BCDEDIT.

When I start my machine up, I'm given the choice of 3 boot configs:

Earlier Version of Windows [this is my old XP system]
Windows 7
Microsoft Windows XP Professional Setup

The third choice invariably comes up as the default. What I'm trying to do is either get rid of that third choice or, at the very least, get it not to be the default.

Attached is a screen shot of my attempt to use EasyBCD 2.0 to remove "Microsoft Windows XP Professional Setup" from my list of boot choices. (Please see attachment easybcd1.jpg.) Note the fact that "Microsoft Windows XP Professional Setup" does not even appear as a boot config, and therefore cannot be removed using EasyBCD.

I've also attached a screen shot of trying to use BCDEDIT to remove my unwanted boot choice. (See bcdedit.jpg.) Same result; the "Microsoft XP Professional Setup" does not appear.

Do you have any suggestions other than EasyBCD to solve this problem? Any advice would be sincerely appreciated.

All the best,
Gnome :smile:
 

Attachments

Terry60

Knows where his towel is.
Staff member
#8

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#9
The only reason why XP Pro Setup would be there is cause you never finished an install of XP. It is right after the first reboot of the install process. It also wouldnt be listed in EasyBCD but in the boot.ini file itself. Sounds like your boot is not set to go from the BCD you have created with EasyBCD.
 
#11
Re: unfinished install of XP

The only reason why XP Pro Setup would be there is cause you never finished an install of XP. It is right after the first reboot of the install process. It also wouldnt be listed in EasyBCD but in the boot.ini file itself. Sounds like your boot is not set to go from the BCD you have created with EasyBCD.
Hi Mak,

Yes, I'm painfully aware of why the XP Pro Setup is there. I just want it to go away now. :smile:

Unfortunately, because this is Windows 7, there's no boot.ini file anymore. That's why I'm at a loss as to how to fix this.

I never created a BCD with EasyBCD; so far I've only used EasyBCD to try to fix the problem I'm having. Creating a new BCD would be an extremely scary thing for me to do, but I would do it, if it would mean a working Windows 7 OS with no more XP Pro Setup boot.

If creation of a new BCD is the right answer, please give me step-by-step instructions, or tell me where I can find them. Assume I'm an idiot. :?? Thanks!

Gnome
 

Terry60

Knows where his towel is.
Staff member
#12
There is still a boot.ini. bootmgr boots XP by chaining to NTLDR. the XP load process is exactly as it always was.
Read the first link in the sticky for details.
You can find the boot.ini in use with EasyBCD > tools > "edit legacy entries"
 
#13
Woo hoo!

Hi Terry,

I didn't realize there was still a boot.ini lying around, and didn't think to go in and tell Windows to show me the hidden OS files. (I had set that option years ago on my old XP system, and had sort of forgotten that new Windows systems are pre-configured not to let you see OS files by default.)

It's all working now! I couldn't have done it without your help!

Sincere and profuse thanks!! :joy:

Gnome
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#14
No problem.
 
#15
i have this same problem. i dont seem to find the boot.ini file.
what about the edit legacy entries. i dont understand how it works.
 

mqudsi

Mostly Harmless
Staff member
#16
EasyBCD | Tools | Auto-Configure
 
#17
Woo hoo!

Hi Terry,

I didn't realize there was still a boot.ini lying around, and didn't think to go in and tell Windows to show me the hidden OS files. (I had set that option years ago on my old XP system, and had sort of forgotten that new Windows systems are pre-configured not to let you see OS files by default.)

It's all working now! I couldn't have done it without your help!

Sincere and profuse thanks!! :joy:

Gnome
How did you do it? Please tell me how :frowning:
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#18
This is a very old thread and will be locked soon. What is it that you wish to know exactly? How to remove XP from boot has already been explained. How to show hidden system files is easy, just display any internal page such as "Computer" and go to the toolbar - Tools > Folder Options > View and uncheck the item "Hide protected operating system files...." and Apply.
 

Terry60

Knows where his towel is.
Staff member
#19