how to boot ubuntu from external drive without drive letter

mhguda

New Member
Hi, I have ubuntu 10.10 on a portable hard drive (60GB) that I use to boot different laptops (not necessarily my own, but mine, too). I can boot via the bios, but I would like to use easybcd and boot from a regular boot menu. The problem is that this drive does not have a drive letter associated with it, so windows (7, 32 bit) does not see it. In easybcd when I try to add its entry it does seem to be present, but when I reboot, ubuntu will not come up, and the entry points to Cdrive (where windows lives). Am I doing something wrong? Will the drive still be bootable if I assign a drive letter to it? It boots fine if it is the first drive in the list of boot choices... Thanks for any help.
 

mqudsi

Mostly Harmless
Staff member
You need to enable legacy USB support in the BIOS.
 

mhguda

New Member
You need to enable legacy USB support in the BIOS.
What do you mean? I see no option in my BIOS menu to enable anything to do with USB. But USB is enabled, I can boot from the drive if I make it the first boot device in the list. What I want is a boot menu that includes booting from it. Will I disable anything if I assign a drive letter from the windows disk management service? Will I be able to include the device as a boot option if I assign it a drive letter?
 

Terry60

Knows where his towel is.
Staff member
Windows cannot assign letters to file-systems it doesn't recognize (like Linux's).
When you say "BIOS menu", are you refering to the BIOS setup utility ?
(the splash screen will tell you how to enter it. e.g "Press 'del' to enter setup". OEMs use a variety of methods)
 

mhguda

New Member
Windows cannot assign letters to file-systems it doesn't recognize (like Linux's).
When you say "BIOS menu", are you refering to the BIOS setup utility ?
(the splash screen will tell you how to enter it. e.g "Press 'del' to enter setup". OEMs use a variety of methods)
Yes, that is what I mean.
 

Terry60

Knows where his towel is.
Staff member
On Phoenix BIOS setup, it's
Advanced > Onboard Device Config > USB Config > Legacy Support
 
Top