how to get esata working on vista

#1
hello there,

good day.
thank you in advance for your time.

ok, pretty good with computers here. built my system actually. just can't quite figure this one out:
bought a western digital drive, formatted the drive using regular internal sata cord, put it in an esata HDD enclosure, connected the external case to an esata port [which just runs internally to a sata port].

both my bios and windows vista 64-bit do not recognize the drive properly. sometimes it's not there at all, sometimes it's considered an indeterminate 8gig drive....

i know the drive and the enclosure work, because it also has a USB port on it, which i used for a while [before formatting it via sata cord].

any thoughts? suggestions?

i've tried switching the sata configuration in the bios to AHCI and RAID, to no avail. i now have it set to IDE [regular/default]. i also tried putting a jumper on the drive to bring it down to 150. that did nothing.

*edit: few other things i forgot to mention: i tried the enclosure set to JBOD and individual drive [or single drive mode] and i only have 1 of the 2 possible drives installed. when i open disk management and try to get it to recognize it, it comes up with the error: "The request could not be performed because of an I/O device error." in cmos the drive comes up as Config Drive 0.
Edit
 

JustinW

Super Moderator
Staff member
#2
Hello K&S,
  • Did you plug in the drive with Windows up or with the machine powered down?
  • Have you tried rebooting the machine to see if Windows well recognize it?
  • Does the drive appear in disk management or does its driver appear in device manager? If it does, do the partitions show or does it show up as unallocated space?
  • If it shows with partitions, give them drive letters and you should be fine. If not, can you "initalize" the disk?
  • Can you boot the disk on its own if an OS is installed there?
  • With Windows up, have you tried re-attaching it?
I had this problem with an SATA/USB adapter. The solution was having the drive powered and than plugging in the connection to the computer. I had been plugging everything in before powering it up, but this caused Windows to finally recognize I had a drive attached.
 
#3
Hi KickingandScreaming,
The first esata pci express card I bought was off newegg and it didnt work, the computer wouldnt even powerup with it in, So I went looking at bestbuy, had none there, fortunately the salesman remember me and suggested it, and a week later a prospeed esata card was on the shelf. Thankyou Bestbuy ! I've been fighting with Esata for a few weeks, I found a card sold at Bestbuy just recently called Prospeed esata, its a PCI Express controller card, It has two esata ports on it that will work at the same time, I have tested it with Windows XP, a driver cd comes with the pci card, Its Sata 1 and 2 compliant, up to 3 GB/second transfer rate, Compatible with Mac and PC desktop. and look what I found, under system requirements I should of read before I typed all this out, it supports Mac OSX v10.4.5 or later/ Windows 2000, XP, Vista. It doesnt support Linux which I was really disappointed about but I'll pester their website and maybe their put out an open source driver for me. Who knows. The esata card cost $41.99 at bestbuy. My hair is no longer falling out. Your probably wondering if theres a noticeable speed difference, they claim 6 times the speed of usb 2.0 and I'd say they are correct. I noticed transferring a 1 gig movie only took about 10 seconds. Usually its somewhere in the neighborhood of 3-5 minutes. I havent done a really big transfer like an entire drive to another drive, thats next on my list of things to do.

Heres the link to their site,
ProSpeed eSATA Card | SimpleTech :: by Fabrik You cant purchase it directly from their site, but it lists all the major stores that do have it. Maybe that will help you. Please let me know if Vista was a hit or miss for you. I want to upgrade a few vista computers. You'd save me the hastle. Almost forgot, it doesn't say anywhere not even on their website if the esata card works with Vista 64 bit. Or Xp 64 bit, so sorry I couldnt help you there.
 
Last edited: