How to remove grub from Vista mbr?

#1
Hi,
I installed Linux on a separate drive from Vista and from Win 7. I had Vista drive connected during installation.
Now when I boot the PC I get Linux grub boot screen with Linux being the first (default) OS.
I'd like to have Vista to boot first, but when I ran EasyBCD, I did not see any mentioning of Linux in the boot record - only Vista. Do I miss something?
Also, I did not have HD with Win 7 connected when I installed Linux, but would like to add it to the boot menu (any boot menu, not necessarily Linux's)

How can I change anything if I don't see any records of grub loader on Vista drive? Am I looking in the wrong place?
Thanks
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Krout, welcome to NST.
When you installed Linux, did you used "advanced" boot loader options ?
The default action of a Linux install is to take control of the boot by overwiting the MBR.
If you wanted Vista bootmgr to remain in control, you should have instructed the Linux install to leave the MBR alone and install grub to the Linux boot sector.
You are now booting with grub, and grub will chain to Vista bootmgr. You will see no option for booting Linux in the BCD because that's not controlling the boot any more - grub is.
You can leave grub in charge and add an entry for W7 to the grub menu.lst, or you can boot your Vista DVD, "repair your computer" / "startup repair" 3 times to put Vista bootmgr back in control (and back in the MBR), reinstall grub on the Linux partition, and use EasyBCD to add entries for Linux and W7 to the Vista BCD.
Alternatively, put W7 first in your BIOS HDD boot sequence, boot W7, Install EasyBCD 2.0 latest build, and add entries for Vista and Linux.
 
#3
Thanks Terry,
It's a little bit too late now for instructing Linux to leave mbr along, LOL, but I like your advise on how to fix the problem. Previously I booted from Vista DVD (full version) but did not see anything close to "repair your computer" or "startup repair". I will try it again.
Thank you

I did find "repair computer" link and used its command prompt to run bootrec/fixmbr, that did the trick.
Thanks for the great tool!!
 
Last edited: