How to restore lost Vista Installation?

#1
Hi,

I had a multiboot installation with Win 7 first installed on a raid array, then Vista 64 installed on another lone hard drive. So I dismatled the raid array and would like to know how to resore the bcd information. I've tried setting it as active with diskpart and bootrec/ fixmbr, though when I get to bootrec /fixboot it throws an error.

There is not C:/Boot/ folder however. I tried the nuclear options on the tutorial without luck. I even tried bootsect /nt60 all /force. I've tried all options including this:
mkdir c:\Boot\
xcopy c:\windows\boot\pcat\* C:\boot\ EXCLUDE:bootmgr /E /C /Q /G /H /R /Y
xcopy c:\windows\boot\fonts\* c:\boot\Fonts\ /E /C /Q /G /H /R /Y
copy c:\windows\boot\pcat\bootmgr C:\Bootmgr
bcdedit.exe /createstore c:\boot\BCD
bcdedit.exe /create {bootmgr} /d "Windows Boot Manager"
bcdedit.exe /set {bootmgr} device partition=C:
bcdedit.exe /timeout 5
bcdedit.exe /create /d "Windows Vista" /application osloader
# You should get a message saying {ID} was created successfully. Use {ID} in future commands.
bcdedit.exe /set {ID} osdevice partition=C:
bcdedit.exe /set {ID} device partition=C:
bcdedit.exe /set {ID} path \Windows\system32\winload.exe
bcdedit.exe /displayorder {ID}
bcdedit.exe /default {ID}
bcdedit.exe /set {ID} systemroot \Windows


But get an error at the xcopy (know its missing a backslash) where it says can't read bootmgr. Guessing maybe the file is locked. Anyone know the correct sequence of commands to make the drive bootable?

I already tried the recovery routine on the install vista cd but it doesn't see the volume. Also bootrec/scanos does see it however so its there just have to restore bootfiles....

Thanks.
 
#2
Hello David, welcome to NST.

Forget the manual repairs.

Disconnect all HDDs, other than the one that Vista is installed to.
Boot from the Vista dvd, set your Vista partition to 'active' if it isn't already, with Diskpart,.and then run Startup Repair 2-3 times to fix everything. That should get your Vista boot working.
Boot Vista, install [thread=642]EasyBCD 2.0[/thread], plug the Win 7 HDD back in (assuming you still have W7 - didn't quite understand what "dismantling the RAID array" meant), add a type-Longhorn entry to your BCD, pointing it at the W7 partition.
That should get your dual-boot working again, with the least amount of difficulty.
 
#3
About the raid array I just went into the bios and recreated the array fresh, so right now the system sees two drives. The array that had the Win 7 partition is now blank. Is it really neccessary to disconnect the all the drives in the array? And is Startup repair suppose take forever? And I guess I should delete the boot folder I attempted to create?

Thanks.

PS: If this doesn't work I'll just reinstall it fresh. I just would like to know how to manually repair it for future hardware configuration changes I may decide to deploy....
 
#4
Yes, you will need to disconnect all HDDs except for the one with Vista installed for Startup Repair to work. It gets confused when it detects other HDDs in your system.
You can delete the boot folder if you want to, but I don't think its necessary. Startup Repair should create its own boot/bcd, and another bootmgr if you need it, as well as write an MBR and PBR to your HDD, if that's corrupted.
 
Last edited:
#5
Failed.

Well it failed to repair the system, so I just am reinstalling it fresh. Not a big deal, the old one was just a week old. Think its a Vista and Win 7 problem...
 
#6
How many times did you run Startup Repair?
 
#7
Weird boot order problem

I only ran it once. Anyhow I reinstalled Vista, Deleted the raid array partition that was marked as Primary within the Vista setup drive config section, and selected the single drive for the install. It rebooted just fine with the CD in the drive but once the cd was ejected I got a Disk not found error. Put the install cd back in and it rebooted back into Vista. Took it out and went into my bios boot order which was:

1. WD1000 (vista install)
2. Velociraptors (raid array)
3. Other

to
1. Velociraptors
2. WD1000

And it booted just fine into Vista.

What went wrong???

Thanks a million.
 

JustinW

Super Moderator
Staff member
#8
Apparently you don't have Vista's bootloader installed on the same drive where Vista's been installed. If you disconnect all the other drives except for Vista's and run startup repair 2-3 times you should be able to fix that.
 
#9
Why is Vista so stupid!

Apparently it looks like the Vista boodloader was on another drive. I disconnected the other drives except my Caviar Black, and am running the repair tool now. Its taking its sweet time. This time it did not see the OS like last time. Its been at least a half hour. If it doesn't work it would be quicker for me to just reinstall it again...

Thanks.
 

JustinW

Super Moderator
Staff member
#10
Open a command prompt instead of going to startup repair right away:

diskpart
select disk 0
list part
select part x
Replace x with number ouptted that represent's Vista's partition (likely 0 or 1).

active
exit
Vista's partition well now be active so startup repair should work faster. Run it 2-3 times. Its not very good at fixing everything at once, especially since it needs to build a new BCD on the drive.
 
#11
Thanks

Thanks,

Everything is fixed now. Reading these forums really helped understand how flawed the windows bootloader system really is. Rather than mess around I did a fresh install. Took two tries. Had to disconnect all other drives to get it right. Now if only Vista would shut down under 30 seconds!

Its no wonder why people are buying macs!

Dave.
 

Terry60

Knows where his towel is.
Staff member
#12
W7 shutdown is really quick compared to all previous versions of Windows.
 
#13
Not fast enough

My Win7 shutdown sometimes takes forever and last time it might have stalled and I had to reboot and then my raid got data corruption which threw it into a long 6 hour verification cycle. I suspect the antivirus software but I was just reading about reviewing the event viewer performance monitors for figuring this out which I will do today,

Thanks.