Hyper-V VM 0x000000ED UNMOUNTABLE_BOOT_VOLUME

#1
I'm dealing with a Windows boot problem that is driving me insane. A Windows Server 2008 R2 VM in Hyper-V started BSODing recently. I was getting various stop codes (0x000000F4 and others). I was able to get into Safe Mode after a bajillion reboots. Startup Repair from a Windows CD seemed to work but the next day it went back to BSODing... right in the middle of making a data backup unfortunately. I ran Startup Repair again but it didn't seem to matter. Now I just get 0x000000ED UNMOUNTABLE_BOOT_VOLUME. When I run Startup Repair it can't find an OS volume and it says C:\Boot\BCD\bootstat.dat is corrupt before running Startup Repair. chkdsk doesn't work since it can't find a volume. bootrec doesn't work since /scanos reports finding 0 installations.

I downloaded the Windows 7 x64 Recovery Disk since it was only $10 hoping that it might help. Unfortunately running "Attempt automated repair" a number of times didn't do anything. I know EasyBCD supports VHD images. Would EasyBCD help any? Any ideas from anyone on what I should do next? We have 6 VMs running on the system without any problems. It is just this particular VM that went haywire.
 

mqudsi

Mostly Harmless
Staff member
#2
You'd have to mount the VHD as a local hard disk from another installation then manually repair the drive image.
 
#3
That's what I plan on doing. I'm currently having issues copying the VHD files just so I have a backup of the original unmodified VHD. Robocopy is choking with error 665 (00000299) file system limitation and then retrying. It seems to eventually succeed though. I researched that error some and all I found is that to make sure that NTFS compression is turned off (it is) and check the host OS defragmentation level. Defrag analysis said the drive had 0% fragmentation which I don't believe. The VHD is a few hundred GB though. Maybe I should also run chkdsk on the host but since this only affects 1 VM, I don't think the host OS is the problem.