I cannot boot from a created USB device after creating it with Easy USB Creator Lite 2.3

Hi everyone,

I cannot boot from a created USB device after creating it with Easy USB Creator Lite 2.3.
The software tells me it is created succesfully. I triend 4 brands of USB sticks and sizes from 32GB tot 128GB. All unpartitioned before creating. I also disabled secureboot and (I work with Dell) boot with the F12 button to select a boot device. My machines only support UEFI, no legacy.

Whatever I do, nothing works.
 

dinsdale

Member
Hi,

I've just ran into this myself. I created the boot usb drive first using "Easy USB Creator Lite.exe". The Easy USB Creator didn't like the multiple partitions on the drive so I used FreeBSD to destroy and recreate the partition table and created a clean fat32 partition on the usb drive (7.52GB). My new Dell Precision 3551 won't see the USB drive in the boot list. It does see the device and I tried creating a boot entry but it didn't help. I disabled Secure Boot, I turned of fast boot and even extended the post by 5 seconds. No love.

Prior to actually wiping the usb stick for EasyRe, I had a KUbuntu installer on the USB stick and grub booted just fine. So I know the USB stick is good and that the computer WILL see a bootable usb stick.

I also tried the EasyRe imaged usb drive in my sons older HP Envy. It already had legacy boot enabled because it's a dual boot machine. That computer will see the usb stick in the list of bootable drives, but it doesn't boot.

For a final test, I used dd to write EasyRe onto the drive, but that didn't work either.
 

RyMcVars

Member
Any Luck with this? I'm having the exact same issue.
I moved over to EasyBCD to see if that would help but basically ran into more issues.
 

Mystery905

New Member
I have the same issue. No Legacy support in BIOS, just able to disable secure boot. No CSM or legacy option.

I think that is the issue.

Need to be able to create UEFI compatible bootable USB drive.

Emailed support and will await their response.

By the way the stick does work in another laptop I have that has Legacy support.
 

mauricev

Member
I am running into the same problem. I tried manually adding a UEFI boot option (it wasn't clear what file it's looking for, but it seemed to have eventually filled this out on its own as \EFI\BOOT\BOOTX64.EFI, but that didn't make a difference.
 
Top