i cannot change drive when creating entry

Status
Not open for further replies.
#1
I am trying to dual boot xp with vista. I started installing xp on my E: partition and got the Disk read failure error. Had to use vista cd start up repair to get back on my machine and read a tutorial to use bcd edit. I am trying to add a entry for xp but it will not give me the option to change the drive to E: from C;
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
When i open EasyBCD i see under the Advanced options the ability to do what you say. If anything delete the previos Windows XP entry and add one thru the Advanced options.
 

mqudsi

Mostly Harmless
Staff member
#3
Hi str8, welcome to NeoSmart Technologies.

EasyBCD automatically determines the correct letter for an XP entry, which is not necessarily the same as the drive that XP was installed to. Rather, it should point to the boot drive which has NTLDR and boot.ini on it.

See the documentation for further info: Configuring the Bootloader - NeoSmart Technologies Wiki

If you want to force it to use a different entry, like Mak said, create this entry, go to "Change Settings" and select a different drive on that screen.
 
#4
Hi str8, welcome to NeoSmart Technologies.

EasyBCD automatically determines the correct letter for an XP entry, which is not necessarily the same as the drive that XP was installed to. Rather, it should point to the boot drive which has NTLDR and boot.ini on it.

Check this documentation for further info: Configuring the Bootloader - NeoSmart Technologies Wiki

If you want to force it to use a different entry, like Mak said, create this entry, go to "Change Settings" and select a different drive on that screen.
Thank you! I had no idea about configuring boot drive but I followed your advice to make everything work fine.
 

Ex_Brit

Volunteer Moderator
Staff member
#5
Good job. Thread closed due to age.
Anyone with similar problems please start a new thread, thank you.
 
Status
Not open for further replies.