I cant boot Ubuntu (9.10).

#1
I had just tried 1.7.2 but when I selected Neogrub or Linux/bsd entry it show(status 0x000000f, file NST/neogrub.mbr). So I downloaded 2.0 last build. If i configure the linux/bsd entry as Grub, the PC restarts. If I configure it as grub2 or if i configure the Neogrub with the Ubuntu menu.lst, it appears this screen:



The menu.lst configuration is that:
Code:
title        Ubuntu 9.10, kernel 2.6.31-14-generic
root        (hd0,3)
kernel        /boot/vmlinuz-2.6.31-14-generic root=/dev/mapper/isw_biacegaeeh_WDBlack4 ro quiet splash 
initrd        /boot/initrd.img-2.6.31-14-generic

title        Ubuntu 9.10, kernel 2.6.31-14-generic (recovery mode)
root        (hd0,3)
kernel        /boot/vmlinuz-2.6.31-14-generic root=/dev/mapper/isw_biacegaeeh_WDBlack4 ro  single
initrd        /boot/initrd.img-2.6.31-14-generic

title        Ubuntu 9.10, memtest86+
root        (hd0,3)
kernel        /boot/memtest86+.bin
And EasyBcd configuration look like this:

Code:
There are a total of 4 entries listed in the bootloader.

Default: Windows 7 Ultimate (recuperado) 
Timeout: 30 seconds.
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7 Ultimate (recuperado) 
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Karmic Koala
BCD ID: {477e5db6-c6f5-11de-8748-ef2347ca5dbe}
Drive: C:\
Bootloader Path: \NST\nst_linux.mbr

Entry #3
Name: Karmic Koala 2
BCD ID: {477e5db7-c6f5-11de-8748-ef2347ca5dbe}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

Entry #4
Name: NeoGrub Bootloader
BCD ID: {477e5db8-c6f5-11de-8748-ef2347ca5dbe}
Drive: C:\
Bootloader Path: \NST\NeoGrub.mbr
 

mqudsi

Mostly Harmless
Staff member
#2
Why does your Ubuntu menu entry look like that?

What is /dev/mapper? Is it a mapped virtual drive?

Typically that should look more like root=uuid=xxxxx or root=/dev/sda2 or something.
 

mqudsi

Mostly Harmless
Staff member
#4
I haven't had a chance to test NeoGrub or any of EasyBCD's Linux support against a RAID configuration.... but I'm pretty sure that NeoGrub won't work with RAID without any additional setup/tweaking.
 

mqudsi

Mostly Harmless
Staff member
#6
Install GRUB to the MBR.
 
#7
I had just reinstalled Ubuntu and I selected the win 7 partition to install the grub at, but it doesnt work, when I restart the win7 boot manager shows up and there isnt any option to start ubuntu.
 

mqudsi

Mostly Harmless
Staff member
#8
The Windows 7 partition is NOT the MBR.

MBR is the actual disk. Not a partition.
 
#9
You're not suppose to select any partition (and certainly not the W7 one!) to install Grub to the MBR. Just leave the Advanced option alone, and let it do the default thing, which is to install Grub to the MBR.
 
#10
First of all, thanks for the answers. I leave the advancen option alone but it doesnt work, it appears an error saying that was imposible to install the grub. I try again selecting the whole disk as grub destination, this time the grub was installed succesfully, but again win 7 starts directly.
 
#11
Ok, now with Grub installed to the MBR, try adding a Linux entry in EasyBCD again.
 
#12
I did, if I add it as Grub, when I select it at the boot screen the PC resests, and if I add it as Grub2, it appears the screen that I had posted above.
 
#13
How many HDDs do you have in your system (both internal and external)?
If you could post the contents of the "sudo fdisk -l" (the last letter is a lowercase L - don't put the quotes in) command run from the Applications>Accessories>Terminal, while booted into a LiveCD session ("Try Ubuntu with No Change To My Computer"), it would be great and allow us to better debug the problem.
BTW, Grub2 uses a grub.cfg file (not a menu.lst), so where did you get those entries from?

Addendum:

Ok, now with Grub installed to the MBR, try adding a Linux entry in EasyBCD again.
Whoops...what the hell was I thinking? :brows:
Obviously, Grub is NOT installed to the MBR, if you say it boots into W7 directly (unless the Grub timeout is set to 0, and the default entry is W7), and if it was, there wouldn't be much point of using EasybCD...

I guess I was too tired last night when I wrote that. :tongueout: I must have been thinking you installed it to the Linux partition.

First, you will need to verify that Grub has been really installed to the MBR. I'm not sure how Grub2 works in this regard, but in Grub1, you can boot from the LiveCD, select the Try Ubuntu With No Change To My Computer option, and run the following commands from the Applications>Accessories>Terminal:
Code:
sudo grub
find /boot/grub/stage1
root (hdx,y)
setup (hdx)
quit
exit
where the "x" and "y" values are replaced with the numbers returned by the find command. x stands for hard drive number, y stands for partition number. By saying install (or "setup") to the drive number (x), without specifying the partition, Grub will be installed to the MBR of that HDD. But then again...that's Grub1, and I'm not sure Grub2 can be installed that way or not.
 
Last edited:
#14
At the end I managed to get dual boot running fine. What I had to do was format as ext3 the 100Mb Ntfs partition that win 7 creates when its installed. Then I mount /boot on it and grub works perfect but I had to manually set Win 7 at menu.lst. A little issue is the error bootmgr not found, but it is easily reparable with the win 7 installation disk. Here is a full guide of the process, but in spanish. Thank you all.