I can't get the bootloader to boot Linux.

#1
I've previously setup another computer to use Vista's bootloader to boot both Windows and Linux.

I am now trying this under Windows 7 with Easy BCD 2.02, and I can't get it to work.

I can get into either Linux or Windows with a grub CD. In Linux, I ran grub-install /dev/sdb to put the first part of grub in /boot on my second disk (/dev/sdb). It claimed I succeeded and listed the device map so I could check it. It was right.

I then went into Windows, ran Easy BCD. Earlier I used it to fix the MBR because originally I had put grub's first segment in it. That worked because now when I boot, with more than one bootloader entry, the Windows bootloader comes up and lets me boot into windows.

But the instructions I found for adding Linux to my boot menu got a bit complicated, compared at least to the instructions I found on the Easy BCD website, and used when I did this with vista..

The latter instructions tell me to go to the Add/Remove Entries page. There is only an Add New Entry Page. The Instructions tell me to choose the Linux tab from the bottom half of the Easy BCD screen. But the screen has two halves with the first, on top, called Operating Systems and the second, on bottom, called Portable/External Media. There is a Linux/BSD tab in the Operating Systems part. I chose that and I got a pull down menu which gave me the choice of grub(legacy), grub 2, lilo/elilo, FreeBSD, and wubi.

I chose grub---which is probably my mistake. The reason I did that was because then the Device pull down menu, let me choose where grub is. I chose Drive 1 Partition 1, which is the boot partition in which I put grub. It is the first partition on the disk. I can tell that Easy BCD has correctly picked it out because it lists its size, which uniquely identifies it.

There is also a checkbox which says GRUB isn't installed to MBR/bootsector. I left that unchecked. Was that right?

But when I boot and choose LInux, the screen goes blank and nothing happens.

If I choose grub 2 instead, Easy BCD says the Device is Automatically configured. How does Easy BCD know where to look if I don't tell it? If I make that choice---which might be the right one---can that do anything to mess up Windows 7 or cause something else not to work?

Any advice would be greatly appreciated. More to the point, where can I find explicit instructions which refer to the version of Easy BCD (2.0.2) which I actually have. The help tab brings up instructions for previouse versions of Easy BCD.

Also, although I think the Linux version of the grub install was done properly, is there some way to check that independently?

I await help. For the present I have to use the grub-CD which I made before starting all of this.

Added later: With my current ssetup, it seems to be using something called c:\NST\nst_linux.mbr
which was created today. What function does this play?

Added still later. I found instructions for dual booting Windows 7 and Fedora on separate disks. They tell me to choose grub(legacy) and then find the device, which is what I did. So I apparently di the right thing, but it still doesn't work.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
#3
If Linux is using legacy grub, pick that.
If Linux is on a different HDD to Windows, tick the "grub isn't ...." box
If Linux is using grub2, EasyBCD will auto-locate it for you.
See the sticky, point 7

http://neosmart.net/wiki/display/EBCD/Ubuntu
is up to date.
Sorry but
http://neosmart.net/wiki/display/EBCD/Fedora
is over 3 years old (see the edit date) and still refers to Easy 1.7

Please use the latest Beta build if you are having problems
I actually have Fedora 14, not ubuntu. Are there instructions for that? Does it make any difference?

How do I tell at the Fedora end whether I'm using grub 2?

Addendum:

Okay.

I tried grub(legacy) and checked the box. This time it didn't let me choose the device but found it itself, and it seems to work now. This by the way is different from the ubuntu instructions which you referred to above.

Thanks a lot.

I guess I will leave well enough alone, since it seems to be working, but I still would like to get straight whether or not I am using grub 2.

Added still later.
Fedora 14 can use grub2, but by default, it uses grub. I don't have grub 2 installed. The description of grub2 warns about using it. Grub2 seems to be much more powerful than grub, but I don't think I need the additional powers. If it becomes the default version in a later upgrade of FEdora, I suppose I will have to reinstall the Windows boot loader using Easy bcd.
 
Last edited:
#4
Fedora 14 uses GRUB-1 (GRUB Legacy) by default. The steps to make the entry for it in Easy BCD are as follows:

Add new entry, select the Linux/BSD tab, under type leave the selection as “GRUB ( legacy)”, under device select the drive you installed Fedora to. Leave the checkbox for “GRUB isn’t installed to MBR/boot sector” unchecked. Next to name type “Fedora”. Click add entry.

Ubuntu uses GRUB-2. Many other Linux distributions use GRUB-1. What Easy BCD seems to be doing when you ask it to make an entry for Ubuntu is it looks for the first Ubuntu partition it can find and looks for the grub.CFG file located in the boot/grub folder.

My setup only has one hard drive. But because Easy BCD is utilizing the MBR on the first hard drive I don’t see why one couldn’t instruct the Fedora 14 install to install GRUB to the MBR of the second hard drive. On my one hard drive setup I instructed the Fedora 14 install the boot loader to the partition that I was installing Fedora 14 to.

During the Fedora 14 installation process, right after you assign what partition you want Fedora 14 to be installed to, the installation process gives you the option of where you want to install the boot loader.

How to dual-boot Ubuntu 10.04 and Red Hat Fedora 14? Jan 07 2011
http://neosmart.net/forums/showthread.php?t=7658&highlight=Fedora

Easy BCD documentation:
http://neosmart.net/wiki/display/EBCD/EasyBCD+Documentation+Home

Fedora documentation:
http://neosmart.net/wiki/display/EBCD/Fedora
 
Last edited: