I have fubared my system

#1
I originally had 5 partitions on my hd. I had one for the mbr, vista, xp, linux swap, and linux. I had 20 gb of free space left on the hd that I wanted to install Solaris on. However, the problem was that when I tried to install Solaris using it's installer it only showed 4 partitions and they all read "other." So I deleted my ubuntu partition from the Solaris partition and installed Solaris to it. Everything was dandy, the Solaris grub booted up and I could boot into Solaris fine. When I tried booting into Vista and XP, they both crashed.

I used the Vista CD and did a startup fix. Then it installed Vista's bootloader and only had Vista and XP as startup options. XP crashed when I tried selecting it, but Vista booted fine. Then I used an XP cd and ran a fixmbr and fixboot and now my system boots straight into XP without any bootloader at all. I still have two other OS's on my system that I don't have access to!

Help me out! I know I can manually edit the Vista bootloader to include other OS's with easybcd, but I have no idea what steps to take or I don't know what to do to make sure that it sees Solaris also. Any advice would be greatly appreciated, thanks.
 

mqudsi

Mostly Harmless
Staff member
#2
OK, first in EasyBCD go to the manage bootloader screen -> reinstall vista bootloader.

Now XP and Vista will boot from the Vista bootloader.

You need to install GRUB to the bootsector of the Solaris partition. It was originally installed to the MBR, and therefore not usable with EasyBCD.

You can see the instructions on reinstalling GRUB here: http://neosmart.net/wiki/display/EBCD/Linux

Once GRUB is installed to the Solaris partition's bootsector, back in Vista (or XP) add Solaris' partition in EasyBCD 1.6 from the Add/Remove Entries' Linux/BSD tab.
 
#3
Alright I got the Vista bootloader back and it boots into Vista fine, when I try to boot into XP I get this error message:

Windows Boot Manager

Windows failed to start. A recent hardware or software change might be the cause.

File: \ntldr
Status: 0xc000000f
Info: The selected entry could not be loaded because the application is missing or corrupt.
 

mqudsi

Mostly Harmless
Staff member
#4
No problem.

What drive is Boot.ini and nttldr on?
What drive is Vista?
What drive is XP?

In EasyBCD, go to the second screen and change the drive of the XP entry to point to the partition with boot.ini
 

Sarge

Active Member
#5
Computer Guru said:
No problem.
That sounded very professional, Guru, yeah I mean it :wink: I like that...
 
#6
Vista is on C:
XP is on D:

I tried searching for boot.ini on both drives and it didn't come up. However, something called bootstrap turned up when I searched for boot.ini on the D: drive.

I tried searching for ntldr and /ntldr and \ntldr on both drives and nothing shows up :/
 
#7
Ok I ran a C:\boot.ini /ah and I found the boot.ini file. I changed the start up drive from D: to C: in easybcd and my vista bootloader can boot up both my windows os's. Great! Thanks for your help so far. Now that link you posted, it doesn't mention anything about solaris... are the directions similar for solaris as they are for linux?