I think iTunes update has corrupted my MBR.

six-h

New Member
#1
Hi Guys, I hope I find you all fit and well!
Before I get on to my current and possibly terminal problem, a couple of odd things happened when I accessed your site today.

First:
Following a link to this page that I have in my "favorites", all my desktop icons reverted to the generic placeholder type blank icons and there was much HDD activity....the icons returning to normal one by one over the next minute or so.
This is not peculiar to your site, it happens on a few sites and it's not important, I just wondered why; and I just know that someone here will have the answer! :lol:

Second:
Entering my username and password (which I have in a secure list so I know it's right!) was not accepted!
Thanks to Gmail search, I was able to trick the system into letting me in to one of my old threads!
I don't recall changing my password and can't seem to get to it in my details.
suppose I'll have to click the "forgotten password link" to change it back to what I have in my list!


OK, now to the REAL problem:
Briefly: I allowed iTunes to update following a nudge from their update reminder.
After it had completed I was asked to re-boot and that's where my problems began!
My PC has hitherto been quite sprightly on boot up, especially considering it's running a seven year old install of that old dog, Vista!
I can usually get from pushing the power button to a working Desktop and fully populated sys. tray in around two minutes.

The initial re-boot after the update was installed never completed and I had to do a hard shutdown as the machine had no GUI and I could not communicate with it.

Re-booting in safe mode, I did get a GUI and opened iTunes..it complained a bit that this that and the other were not present but it eventually opened.
I restarted in normal mode and after a long wait, the desktop appeared...but it was in four segments, none of which matched...bit like a jigsaw that wasn't put together properly....that also eventually resolved it's self out and I tried a Sys. Restore to a point before the update.

(I was annoyed to note the arrogance of Apple, in not triggering an automatic restore point for their updates.:lup:smile:
That completed, I hoped to have my machine back to the previous undamaged state...alas no!

Now it takes a full 15 minutes. to build a complete dektop with fully populated Sys Tray.
A couple of minutes after that, I get the following "Message Window":-
From "57xx SteelVine Manager":-
Which says:-
"Could not connect to host 'localhost'. port 51116"
This is acompanied by a yellow triangle with a black "!" and an "OK" button.
On clicking it the message goes away and I'm not aware of any side effects!

Having remonstrated with Apple support in Ireland, they say it's impossible that their software could have done this as it has no access to these files.
Their only suggetion following this weak defence, is to remove iTunes completely and see if the problem persists, then to use the MS "FixIt" site to correct the problem.
Such child like faith is alarming considering this is the face of Apple Support!

My suspicion is that the MBR has been corrupted.
(I know that sounds as if I know what I'm talking about, but trust me, I don't! :lol:smile:
Is there some process by which I can find out if that is the case and maybe repair it? :scared:

If it helps, I could talk you through the boot up "events" giving details of the screen, times to next change of screen, amount of HDD activity etc.
Hope someone can shed some light!
 

six-h

New Member
#2
Not so much a reply as just a quick update.
I found this article:- http://www.dewassoc.com/kbase/hard_drives/master_boot_record.htm
which I could actually understand and might be useful to other folks stumbling around in the dark!
It explains the MBR and the processes involved in booting a PC in "normal" language! :lol:

Just to be completely contrary, my PC booted almost perfectly today...for the first time in 5 days!
Just hoping that it has maybe healed its self....could it actually do that? :happy:

Wonder if it has anything to do with the fact that the 57xx SteelVine Manager seems to have found port 51116, since it's not complained about it sofar this boot. :brows:

If anyone has any experience of this sort of thing, I'd be pleased to hear

Found this in a PDF

Manage the Client Connection to the Daemon
The SteelVine Manager software consists of two modules:
• Daemon: a background process that establishes communication with the SteelVine
Storage Processors (implemented as a Service on Windows platforms)
• SteelVine Manager GUI: an application that provides the graphical user interface
The daemon monitors the status of the SteelVine Storage Reference Design. By default, the
user interface attaches to a daemon running on the same host to display the information
gathered by the daemon. You can configure the user interface to display information tracked
by a daemon running on a remote host. Having the user interface remote to the daemon
allows remote monitoring for system fan and hard drive failures. Identification of a failed
part may then allow the service provider to replace failed components before further
complications arise.
Prerequisites
Ensure you have the following before you establish the remote connection:
• The daemon software is installed and running on a host computer connected to the
SteelVine Storage Reference Design.
• The SteelVine Manager GUI software is installed and running on a remote host
computer.
• A TCP/IP connection can be established between the daemon and the user
interface. The daemon listens for connections on TCP port 51116. Do not change
this port number.

I don't understand what I've read, but it seems to imply that since the "57XX SteelVine Manager" message has not re-appeared, it must have found port 51116 again...since it seems that is the only one it can work with?

The document I'm reading is here:- http://www.siliconimage.com/docs/SiI57XX_Users_Guide_Rev_1.0.pdf
Page 87.

I just can't understand what the implications might be of losing the connection.
If I understood that, maybe it would explain the horrendously long and pecuilar boot up I've been experiencing.
Hoping that it will now hold, and my problems wil be over.:smile:
Anyone know anything about SteelVine and its raison d'être??
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#3

six-h

New Member
#4
Hello Terry, thanks for that link.
That confuses the situation even more!
My PC has only one 500GB disk divided into 4 partitions:
C/: Operating system........and some software that insists on residing there!

D/: Recovery...........This was designated by the guy who built the system for me, I've never used it and I'm surprised to see there are 34 Folders in there all with long alphanumeric strings as their names and all except one are empty!
The odd one has a 40.8 MB File in it, MRT.exe (Windows Malicious Software Removal Tool) created 19th May 2011this date is of no known significance. (the machine was built in July 2007)

E/: Applications.....those that will allow me to direct them here!

F/: Data.

SteelVine has been on the system from the off, and I thought it was just a background service which I didn't need to know about especially since I haven't seen a GUI for it!
Could it be that it was on the Motherboard setup disk...It's an ASUS P5Q3 Deluxe/WIFI-AP iP45 Socket 775 Motherboard.
I can't remember any other disks being used other than the OS Install disks and I can't imagine it was on that.

Now that you have added "RAID" to the mix, I'm totally nonplussed.
I always thought of RAID as being an array of Drives to either mirror data for security purposes, or otherwise record data across several disks for swift retrieval.

Just for info, last AVG (Free) 9 scan was 24th and clean
Yesterday I did full scans with both MBAM and SAS again both came back clean.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#5
I have an ASUS mobo with multiple disks but no RAID, and I don't have it installed.
Sounds like you can just uninstall it and remove any effect it's having on your boot time.
 

six-h

New Member
#6
Thanks Terry, uninstalling rather goes against the grain, because I have no idea where it came from, nor have I the means to re install it!:brows:
Could I just "disable it" in msconfig and have the same effect?
Since I had this lovely perky boot experience today, I'm really hoping that I don't need to do anything.
....though "Computer, heal thyself", I fear would invoke the unhelpful response...."invalid command"! :lol:
I still live in the hope of many two minute boots in the future!

I noticed that the link you gave me to RAID seemed to indicate that, as with much good software, beneath the skin, linux lurks!
Maybe those guys might be able to shed some light.
I've entertained myself with various flavours of linux, and found the community most helpful, as are you guys, but I've got some way to go before I can even call myself a "Linux Newbie"!
 

Terry60

Knows where his towel is.
Staff member
#7

six-h

New Member
#8
That sounds sensible!
I'm just a bit foxed as to why it's there and what might disappear with it!
Before uninstalling, it may be prudent to disable first, if nothing goes bang, it's gone!
Just checked Progs and features and it isn't listed, so not sure how to uninstall it anyway.:wtf:
 

mqudsi

Mostly Harmless
Staff member
#9
My initial thought on seeing the title of this post was to say the same thing Apple Support told you: it *really* shouldn't be technically possible for an update to iTunes to affect your PC in the manner that you describe.

Unlike most desktop software, iTunes *does* have some kernel-mode components (namely the iPhone/iPod drivers/extensions), but those are all loaded post-boot. The only thing I can think of is that perhaps a Windows update was applied in the background in the same "session" as your iTunes update? I had to format and reinstall over the weekend because of a nasty WU, ended up rebuilding my own RAID as a result.
 

six-h

New Member
#10
Hi Mahmoud, nice to hear from you.
I trust you are well in spite of your RAID problem...that would have been a total disaster for the likes of me!

Maybe you have opened another can of worms for me!

I have an iPad, so I suppose there would be associated drivers etc. for that, I just looked at my update history, and there have been no MS updates since 17th August when 13 important ones, all succeded.

I also have a Galaxy S3, and looking at the MS Updates, it reminded me that when I attached my phone on Aug 17th, an update was triggered; a Samsung one but delivered via MS Updates.
I was unsure what to do so ignored it untill I had disconnected my phone...I had assumed that though it was from Samsung, it was intended for my PC, as it was being offered by Windows Update.
It promptly failed, I tried again and it again failed.
Surely if it were intended for my phone, it would have been delivered to it directly, not via Windows update?
The update was entitled:-
"SAMSUNG Electronics Co., Ltd. - Other hardware - SAMSUNG Mobile MTP Device"

I now notice though this was two attempts at installing the same update, the Fail Reports lists the first attempt as "Recommended", and the second abortive attempt as "Optional"!
Some time ago, I installed Samsung "KIES" software intended for communication with the phone and managing files, backups etc.
It is the absolute pits, the worst and most problematic software it has ever been my misfortune to encounter.
I am amazed that a company which makes such a magnificent phone, can at the same time offer this horrendous software intended to compliment it!
That too triggered windows update to offer me some Samsung updates, again they failed...I gave up but later, at the next Patch Tuesday I found that none of the MS updates offered, would install.
I eventually ended up speaking to one of their support staff in Portugal, who wanted more than an OEM copy of Win7 to help me since Vista is no-longer supported.
..Quite reasonably so! he kindly suggested that I should sys restore which *might* restore what ever reg keys had been corrupted and "unblock" my system so that updates could be installed.
..Fortunately it worked but it made me realise that these apparently benign updates delivered via a trusted source can sometimes really "rock your world"!

I'm just hoping that these two MS Update failures have nothing to do with my current problem!
Anxiously awaiting Sept 10th batch of updates to see if they give me any problems.

That was a bit of history I really thought had been put to bed.

As I have said to Terry, I'm totally bemused that I have had RAID Management Software running on my PC from the beginning...seems a bit much to manage a single 500GB Spinpoint HDD. :wtf:
 

six-h

New Member
#11
Well folks, without wanting to tempt providence, my PC appears to have smoothed down its own ruffled feathers!
I have had my second 2 minute..ish boot in succession and it's rather telling that there is once again no message from 57xxSteelVine Manager saying it's lost its Mummy or that it can't find port 51116. :lol:
I think maybe I've had a lucky escape!
Mahmood's experience due to a Windows update has made me think that I really should take more regular images of my system.....no matter how creaky it is, it's mine and I'd be lost without it!

Just checked; my last recorded image was June 22nd ...2012. :lup: ...room for improvement!
 
#12
So the problem has seemingly righted itself? Hopefully it doesn't get you any more jip, never heard of itunes misbehaving that way before.
 

six-h

New Member
#13
Hi OmarkH, yes, pretty much back to how it was before, just the odd slight quirk.
For instance when the Desktop appears now, it is just blank at first, ie. just the wallpaper and an empty taskbar....then it changes to a fully black desktop before my usual wallpaper and various shortcut icons appear!
Most odd, but I can put up with that as long as my DT. appears and I have a working system within 2/3 minutes of applying power!

I'm probably being unfair to iTunes, as it don't take much to throw this old girl off kilter these days!
I really must invest in a new OS, not sure if W7 is the new "XP", and "W8" the booby prize (like Vista!).

I'm thinking possibly of using this machine for a 64 bit Linux system and maybe getting a Desktop replacement beefy laptop....or not!:lol:
 
#14
I'm probably being unfair to iTunes, as it don't take much to throw this old girl off kilter these days!
I really must invest in a new OS, not sure if W7 is the new "XP", and "W8" the booby prize (like Vista!).
That's probably a part of it, but I know what it's like to be reluctant to change your set up, when you've gotten it how you like it.

Mine has been puffing and wheezing a bit recently, and I'd been thinking of making the jump to a hardier laptop.
 

six-h

New Member
#15
I agree, you do get in a rut and resist making the change!
Thing is, I'm getting used to this sort of "internet grazing" lifestyle that the iPad and smart phones have brought to us.
I find that rather than sitting at my desk for long periods, I tend to have one or other portable device near me and can do most of my browsing, answering mail etc without needing "the beast in the corner" except for when serious "grunt" is required!

I'm thinking of relegating my PC, scanner and printers to an "Office"....AKA the dining room! :brows:
I no longer entertain or hold dinner parties and it would free up some real estate in my lounge...win win!

My iPad has made me much more difficult to please regarding the purcase of a laptop, especially as a DT. replacement, as they are not very portable, and you are paying for a battery that will probably live and die without actually being needed!
The more I think about it the more I seem to be talking myself out of a laptop all together!
That said, I might just dual boot this machine with Linux and some flavour of windows in an OEM package. :happy:
 
Last edited:
#16
I'm thinking of relegating my PC, scanner and printers to an "Office"....AKA the dining room! :brows:
I no longer entertain or hold dinner parties and it would free up some real estate in my lounge...win win!
This is a much better use of space!

"internet grazing" is a good description of it actually. I find myself in this habit. My phone was getting repairs done last week, and I swear i was getting the shakes. :??
 

six-h

New Member
#17
My phone was getting repairs done last week, and I swear i was getting the shakes. :??
Think I would too, not just withdrawal symptoms though, anticipation of the repair bill.
 

mqudsi

Mostly Harmless
Staff member
#18
Glad you got it working again.. Sorry for my delayed replies.

Yes, I very much recommend a regular scheduled backup. I was very much guilty of the whole "not practicing what you preach" thing on this matter until a few years back when I was bit badly enough to learn from my mistakes (let's hope). Windows Vista and up (at least, some SKUs) should have a fairly-decent automatic backup option that's not too terrible to use.
 

six-h

New Member
#20
No, I'm still running, or rather limping along with Vista!
I'ts slowly dying, so I'll probably be forced to "upgrade" probably to W7. :lol:

Edit:
found this, second item might help you.
http://www.apple.com/uk/support/itunes/install/
 
Last edited: