Impossible to remove boot menu!

#1
Hey guys

I realy need some help getting rid of this damn boot menu.
I used a dual boot for a while and now i dont want to have a dual sinds i didnt use it as often as i thought.
So i already tryed removing the entry's but that messed up everything so i had to reinstall my entire windows , because it didnt want to boot anymore.

And the nice little button that says skip boot menu doesnt work either.

So please any help or suggestions because im getting sick of this program:booyah:

With friendly regards Barbecuesaus
 

Terry60

Knows where his towel is.
Staff member
#2
More detail please.
What's the OS ? What were you trying to dual boot with it ? What entries did you remove ? Did you delete the entry for the one you were keeping ??? If you've reinstalled the OS from scratch then EasyBCD won't be on the system and you shouldn't be seeing a menu. (The menu is pure MS, nothing to do with EasyBCD. That just helps you adjust the contents). How did you "reinstall" ? Do you mean you overwrote your OS with a backup image, used an OEM recovery or "factory reset" ?
Can you please post the contents of EasyBCD "view settings" (detailed mode)
 

YSbird

New Member
#3
Hi Terry,

I'm having a similar problem. I had a dual boot with Vista and Win 7 on two separate HDs. I finally decided I no longer need Vista so formatted and wiped the partition that Vista was on. Then I uninstalled easybcd. However, upon restarting my pc. The Boot menu still came up showing both choices. I did make an image of my C drive (Win 7) so put that back on my pc. Once done I went into easybcd and deleted the entry for Vista, then uninstalled easybcd again. But that Boot menu is still there.

I figure I did something wrong, but can't figure out what I missed.

Any suggestions?

Thx

Addendum:

P.S. To above

Forgot to mention that I still have an image of the Vista drive, so if I need to restore it I can.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
Install the very latest Beta of EasyBCD, look in Tools>Options and make sure that "automatically load......." is not ticked.
You might be looking in (and changing) the wrong BCD.
If it is ticked, untick it, start EasyBCD again and delete the Vista entry again.
 

YSbird

New Member
#5
Hi Terry

Your suggestion didn't work. However, what finally did work was unchecking the Win 7 entry after deleting the Vista entry AND checking the Skip Boot Menu. I hadn't done that before as the OP said it hadn't worked for him. I figured I had nothing to lose by checking it and it worked.

At this point I still have Easybcd on my pc, so since what I did works, I'm not going to mess around with trying to uninstall it again and just leave it the way it is.

Thx.
 

Terry60

Knows where his towel is.
Staff member
#6
Yes, I would have moved on to that after checking the other possibility first.
The skip option normally works, though it should be completely unnecessary for a BCD with only one system.
Sometimes though the BCD gets itself a bit twisted and that tick will do the job as a workaround.
A proper fix is to use "reset BCD" then add the W7 entry again, and the tick should prove superfluous.
 
#7
More detail please.
What's the OS ? What were you trying to dual boot with it ? What entries did you remove ? Did you delete the entry for the one you were keeping ??? If you've reinstalled the OS from scratch then EasyBCD won't be on the system and you shouldn't be seeing a menu. (The menu is pure MS, nothing to do with EasyBCD. That just helps you adjust the contents). How did you "reinstall" ? Do you mean you overwrote your OS with a backup image, used an OEM recovery or "factory reset" ?
Can you please post the contents of EasyBCD "view settings" (detailed mode)
Alright lets see. I use Windows 7 ultimate i have used a dual boot with windows Xp i previously removed all entry so none of the systems would boot. Thats why i reinstalled the entier OS again. So now i only have win 7. I reinstalled the OS with a HD format from the DVD Here are the view settings:

Windows Boot Manager--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {5a77db79-76dc-11e1-962f-a68510af5ef5}
resumeobject {5a77db75-76dc-11e1-962f-a68510af5ef5}
displayorder {5a77db79-76dc-11e1-962f-a68510af5ef5}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30
displaybootmenu No


Windows Boot Loader
-------------------
identifier {5a77db79-76dc-11e1-962f-a68510af5ef5}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows 7
locale en-US
osdevice partition=C:
systemroot \Windows
numproc 2
usefirmwarepcisettings No
 

Terry60

Knows where his towel is.
Staff member
#8
Have you read the rest of the thread since your OP ?
It contains the things to try next.
 
#9
No all the above mentioned solutions do not work.
For 1 i cant untick the windows 7 as Ysbird mentioned in his last post.
the rest i have read and tryed with no results.
 

Terry60

Knows where his towel is.
Staff member
#10
a) You're using the latest Beta ?
b) You've checked that Tools > Options has nothing in the "Automatically load..." field ?
c) You've clicked the Edit Boot Menu > Skip Boot Menu button ?
d) You've tried BCD Backup/Repair > Reset BCD... > Perform Action
followed by Add New Entry > Windows > (type)Vista/7 (drive) C > Add Entry ?

(do not reboot without doing both parts of d) or you'll end up with an empty BCD as you did when you deleted XP and W7 and had an unbootable system. (incidentally you needn't have reinstalled W7. "startup repair" from the W7 DVD would have got your boot back)

And you still get a boot menu with one entry ?
If so please post a Disk Management screenshot and the contents of "view settings"
 
Last edited: