Insert Linux to Vista



I installed Suse to another HDD on my PC. As it didnt recognize my Vista installation I recovered the Vista bootloader and tried to add suse. I did it like you wrote it in the FAQs but when I boot up, I do get the bootmenu with 30sec timer. Even if I set Linux to default boot Vista starts booting immediately.

I dont know what to do now :wink:

Here are my Settings:

and the Detailed Settings:

Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device boot
description Windows Boot Manager
locale de-DE
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
resumeobject {96c00895-a250-11db-ae5e-d0b3ce4274b1}
displayorder {96c00894-a250-11db-ae5e-d0b3ce4274b1}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30
Windows Boot Loader
identifier {96c00894-a250-11db-ae5e-d0b3ce4274b1}
device boot
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale de-DE
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice boot
systemroot \Windows
resumeobject {96c00895-a250-11db-ae5e-d0b3ce4274b1}
nx OptIn
detecthal Yes
Real-mode Boot Sector
identifier {64f27e8c-f4e6-11dc-9a15-00179a755a1b}
path \NST\nst_grub.mbr
description Linux

HDD 0 Partition 0 is Vista which has the bootloader installed.
Grub got installed there too as I installed Suse but got wiped out by the "repaired" Vista bootloader

I hope you have any idea :wink:

Greetings Sea
So are you saying that the Linux part did not work? Are you trying to have SuSe be the default?

If you want SuSe to be the default you have to change that setting under the Change Settings button. It will give you the Default OS and timeout option. Just put what OS you want and change the timeout to what you want. Then click save.

Is that what you are looking to do? Did it work? If not go under the Manage Bootloader button and Write the MBR. That should help your settings hold.

Have you read thru the Linux part of the Wiki for all the info we have to help people along with this process?

Linux - NeoSmart Technologies Wiki

Let us know what else you need to know.

Welcoem to NST Sea!

I want Vista to be primary, but thats not my problem at all. The problem is that i dont get the menu to choose any of the systems. The PC automatically starts booting Vista without giving me the option to choose :wtf:
Hi Sea, welcome to NST.

There's a mis-configuration with your system that's causing the menu to not appear.
EasyBCD -> Useful Utilities -> Power Console:
bcdedit /set {64f27e8c-f4e6-11dc-9a15-00179a755a1b} device boot

Then reboot and the menu should show.
now I have the Bootmenu. Thanks so far :wink:

But Using this entry causes an error saying \NST\nst_grub-etcetc cannot be found.
As there was no folder with this on C: i created one and copied the .mbr files into it.
Worked so far as I dont get THIS error any more, but anoter one saying "cannot boot from harddrive".

I dont see where i can teach this bootloader from where to boot...

Current situation is:
I've reinstalled Linux on the second HDD with its own bootsector ( unplugged the Vista HDD during installation ). I can boot both systems on their own by selecting the harddrives via BIOS as primary boot.
So Both drives have their own full bootsector. Is there any way to call the sector of the second drive via the Vista bcd crapwhateverhasnobootiniwhichworkedsonice