Install Bootloader to MBR -> Missing Operating System

#1
edit:

Solved it!
My encrypted storage disk had a higher boot priority than my system disk in BIOS.
(it's marked active as well... don't know if it always was)

Though this never seems to have been a problem before... it became one when hitting the "install bootloader" button.

Vista / 7 boot again... yet, Linux's broken now. Gives me only a "grub>" prompt :frowning:
=========================================



Now it happened. :|

I installed Ubuntu and followed your guide here.

Ubuntu - EasyBCD - NeoSmart Technologies Wiki

Step 2 in the second paragraph proposed to write the Win 7 bootloader in the MBR.

Now after restart I only get "Missing operating system". :frowning:


System is a RAID drive.
Drive boots from Vista partition
I used Win7 to make the change with EasyBCD

EasyBCD complained that it couldn't load the boot info automatically.
So I pointed it to the \boot\ dir manually.


- I can enter WinXP through a UBCD4win Boot CD (easyBCD won't start though)
- I can enter Ubuntu with the Ubuntu Live CD

With the WinXp Boot CD I can run bcdedit.exe from the EasyBCD dir... but it says: "The boot configurator data store could not be opened"
Might try the other exes in there:
bcdboot.exe
bcdedit.exe
BootGrabber.exe
bootpart.exe
bootsect.exe
contig.exe
grubinst.exe

But I don't want to worse things... :-/

Hum... What now? Try to repair the bootloader with the Win7 DVD?


Addendum:


Tried this repair guide: Recovering the Vista Bootloader from the DVD - EasyBCD - NeoSmart Technologies Wiki

bootrec.exe /fixmbr

> OK

x:\boot\bootsect.exe /nt60 all /force

> OK

del C:\boot\bcd

> The "BCD" file wasn't there any more (had been still there one hour ago? Made a backup though)
edit: I was still there but hidden, del couldn't find it... renamed it


bootrec.exe /rebuildbcd


> Found 2 OS:
P:\Windows
N:\Windows

add? Yes

"The volume does not contain a recognized file system."

This FAQ claimed this error rises from
the windows partition not being active. It is active and I set it again to active with diskpart.
Still the error stays.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Glad you got it working.

Each disk can have up to one active partition, but only the active partition on the highest priority boot disk will be looked at.
 
#3
Hm. So it was EasyBCD which destroyed my TrueCrypt Storage drive which was unfortunately the first drive?

Either Ubuntu or EasyBCD must have made it active and has overwritten TrueCrypt's header on that partition
and I ended up with 700gigs of unaccessable encrypted rubbish.
 
Last edited: