instructions are wrong for FC 13 - no choice where to put grub!

Discussion in 'EasyBCD Support' started by corona79, Jul 18, 2010.

  1. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I installed Fedora 13 from a DVD to my Windows 7 computer. Unlike what the instructions below state, there was never an opportunity to choose where to put GRUB. There was no page with an option to "Configure advanced boot loader options.

    Thanks to this incorrect instruction, the computer reboots to grub, and I must quickly stop the process by hitting Enter, then choose to boot Windows.



    Step Four
    Fedora is one of the operating systems out there that understands the needs of dual-booters and makes it easy to get things working. To this end, once you continue on to the next page in the Fedora setup process, you'll be asked where you'd like to install GRUB, Fedora's bootloader. On this page, just check the "Configure advanced boot loader options" box and press "Next" to continue. If you have entries other than "Fedora" in that list, you may want to remove them for a smoother dual-boot procedure later on.
     
  2. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,367
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phoenix, AZ US
  3. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    No such options/screens - those instructions are obviously for an earlier version.
     
  4. Mak 2.0

    Mak 2.0 Mod...WAFFLES!?!? Staff Member

    Joined:
    Jul 6, 2006
    Messages:
    4,270
    Likes Received:
    0
    Trophy Points:
    36
    Occupation:
    Online Support Tech
    Location:
    The Source
    Yes they are for an earlier version. Look at the last time that article was edited. Dec of 2007. With all of the work we have put into creating and testing EasyBCD 2.0 we have not had time to update all of the documentation for all of the recent releases of Linux and GRUB and so on. We are currently working as fast as 4 people can to update all of the documentation and continue to debug and test new version of EasyBCD 2.0 so that we can offer you the best support and options we can.

    So yes our documentation is out dated. But at the same time Fedora did offer this. So that is something that was removed from Fedora by its developers, not by us. To resolve the issue, use the steps listed here to recover the BCD so that you dont have to go through GRUB first.

    Sorry that the documentation fell behind, but 4 people can't quite keep up with the amount of stuff that needs to be done. We are only human after all.
     
  5. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Again, those instructions simply don't apply to the software as it is - I can't go to the "Bootloader Management" window when there is none.

    After repairing the boot sector - what about grub then? How will the computer be able to boot to FC afterwards?
     
    Last edited: Jul 18, 2010
  6. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,367
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phoenix, AZ US
    Add a grub-legacy entry for Fedora using EasyBCD.
     
  7. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I still don't know how to fix the original problem, so the Windows boot loader / EasyBCD comes up in the first place.

    I also don't understand how to add a "grub-legacy" entry.
     
    Last edited: Jul 18, 2010
  8. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,367
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phoenix, AZ US
    EasyBCD > Add New Entry > Linux/BSD tab > Point it to the right partition > Add Entry
     
  9. Mak 2.0

    Mak 2.0 Mod...WAFFLES!?!? Staff Member

    Joined:
    Jul 6, 2006
    Messages:
    4,270
    Likes Received:
    0
    Trophy Points:
    36
    Occupation:
    Online Support Tech
    Location:
    The Source
    You are making this far more complicated than it is. I already gave the link. It instructs you on how to use EasyBCD from within Windows or how to use the Windows DVD to fix the boot problem. You already said you could get into Windows, correct?

    So from there run EasyBCD 2.0.1 and use the Backup/Repair options. There Re-create/repair the boot files. This will restore the BCD. After that you go back to Add New Entry and add an entry for Fedora.

    I dont know why you trying to use the documentation even after i specifically stated it is out dated and needs to be updated. It is for Fedora from 2007 and for EasyBCD version 1.7.2 which is now outdated. Your using the wrong documentation for the wrong version of the program.

    I did give instructions on how to fix it, you must have missed them in my last post.
     
    Last edited: Jul 18, 2010
  10. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    What determines what is the right partition?
     
  11. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,367
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phoenix, AZ US
    Should say extxfs ext2fs etc etc. Wherever it is that you installed Fedora. If you're unsure, post a screenshot of the dropdown/disk management.
     
  12. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I've tried 4 and 5, but neither works. Trying to boot to the new entry just brings up a blank screen with a blinking cursor

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  13. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,367
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phoenix, AZ US
    Partition 5 appears to be it (Partition 4 is way too small unless it was mounted as /boot at setup). It appears you'll need to install grub to Fedora's partition. You can do this with Fedora's livecd from a terminal.

    Heres an example using a Ubuntu cd. If Fedoras still not using grub2 it should be just about the same. At setup though you're going to want to include ",y" so its "setup (hdx,y)" and not "setup (hdx)" so its installing to the partition, not the disk. Re-add the entry in EasyBCD for good measure and than reboot to test.
     
  14. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Instructions from ubuntu forum did not work, booting from Fedora Live CD. First, could not sudo, so used su to run grub, but the "find /boot/grub/stage1" command failed with "Error 15: File not found"

    For whatever reason, it seems like Fedora Core is now designed not to play nicely on a Windows computer. I now have 2 useless partitions on the HD, and don't see any reason not to get rid of them.. I'm thinkng of trying ubuntu, since it comes with a Windows installer, so am hoping it won't take over the computer like FC wants to.
     
  15. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,367
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phoenix, AZ US
    WUBIs a great way to get used to Ubuntu, without the need for complicated setups. Put in the Ubuntu disc when you're in Windows and you'll have it up in no time.
     
  16. corona79

    corona79 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    You already know what happened :rolleyes:

    Wubi failed to install - I posted on an ubuntu forum, but haven't gotten any help so far.

    I got the desktop ISO. I can bring up the "trial Ubuntu" but it's not meant for regular usage. Upon trying to restart, it crashes and I am forced to unplug the computer

    I then tried to install from the CD. The installation would not let me put the boot loader on the newly created partition (as the instructions here state otherwise once again) The new device was /dev/sda5, but the "OK" button was disabled, so I had to give up again.
     
  17. JustinW

    JustinW Super Moderator Staff Member

    Joined:
    Apr 21, 2008
    Messages:
    4,367
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Phoenix, AZ US
    Where did WUBI installation go wrong? It doesn't install to a partition, it simply creates a file on the Windows partition that contatins the Linux filesystem, and adds an entry to boot from it to the Windows bootloader. You can uninstall it from Programs & Features or Add/Remove Programs from control panel just as easily as well.
     
  18. Harley51

    Harley51 New Member

    Joined:
    Jul 20, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    Yes there is an advanced button on Fedora 13 to tell where you want to put grub. Here's the problem that I had and how I fixed it. Mind you I have Fedora 13 on a second hard drive.

    Fedora 13 Goddard Stuck on Loading Partition​
    During install I chose to load Fedora 13 to /dev/sdb7 (Which would be hd1,6 on my system) and install Grub to that partition. Since it’s my second drive the HD number should have been hd1,6 but during install it assigned it to hd0,6 which is my first drive. It loaded the system to /dev/sdb7. But since it was looking for the install on hd0,6 it hung on Loading Partitions. It also loaded Grub somewhere but not sure where.

    Correction:

    Boot DVD
    Chose Rescue Installed System
    English (Chose OK)
    US (Chose OK)
    Do you want to start the network interface on this system (Chose No)
    Then chose continue
    Then chose sdb7 Fedora 13 (Or whatever your system is loaded on)
    Then chose OK
    Then chose shell start shell
    Chroot /mnt/sysimage
    Now change directories /boot/grub
    I use vi grub.conf
    Press the I key to insert text
    Rename splashimage from splashimage=(Hd0,6) to (Hd1,6)
    Rename root (Hd0,6) to (Hd1,6)
    Press ESC to exit insert
    Press shift : hit enter
    Hit w (enter)
    Press shift : hit enter
    Hit q (enter)
    You should still be in /boot/grub/
    Grub-install /dev/sdb7 (or what ever you put grub)
    sync;sync;exit;exit
    Then reboot

    You should be fixed
     

Share This Page