Invalid boot.ini;ndetect failed...

btovrea00

New Member
After using EasyBCD 2.0 Beta to "fix" my dual boot system (I elected to "copy the essential NTLDR and NTDETECT.COM files to the proper location and to create a properly configured BOOT.INI"). On rebooting the system and selecting WIndows XP, the following errors were displayed:

Invalid boot.ini
ndetect failed

My system is configured as follows:

DIsk 0 is the boot disk. It contains 2 partitions, F: for data storage and V: for the Vista OS.
Disk 1 contains 1 partition, C: for XP OS;
Disk 2 contains 1 partition, E: for Backups.

Any ideas how to fix this would be greatly appreciated.
 

JustinW

Super Moderator
Staff member
Hello,

The files are in the right place, you should not mess with them. You can either:

a) reverse the changes you made if you remember what you changed
b) re-add the entry for XP again and let it autoconfigure. If it doesnt ask this time you may invoke it: Tools -> autoconfigure boot.ini.
 

btovrea00

New Member
Thanks for the quick reply...but

I tried Tool::Autoconfigure. Still didn't work. So, a couple of odd things - when I added the Windows XP entry, it auto-selected the C: drive. But the settings shows:

Microsoft Windows XP...Drive F:

I suppose that could be correct so I checked F:boot.ini. It shows:

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP on C:\" /fastdetect

This looks correct to me. But the error message also states something about booting from C:/windows/

I tried to view the boot.ini on the C: drive, but get the old "Access Denied" error. Tried grabbing ownership but that seem to fail.

Any other ideas before I try a restore boot for Windows XP?
 

JustinW

Super Moderator
Staff member
In Vista taking ownership of boot.ini doesnt work as you can see. Though in the administratior group, you do not get access unless you remove the read-only/system attributes and add yourself to the permissions list. I would rename it to boot.ini.old, and try re-adding again with EasyBCD.
 
Top