Ireboot 2 does not work on windows 10

Not open for further replies.
Did you reinstall from the link Peter gave you, or just your previously downloaded version ?
It seems there's more than one thread about this topic right now.

Windows 10 has a new feature that lets you manage startup components. I imagine there's a good chance it's the problem here. Make sure that under "Startup" in the Task Manager, iReboot appears and is enabled (note that that is the default state, it would only flip to disabled or delayed if you manually/inadvertently changed that via right-clicking on it):

iReboot startup status.PNG
Terry60 - Sorry. Just did from Peter's link and does not work. Is same version as my prior anyway.
Mahmoud - iReboot is listed and Enabled in Startup, as it's always been. iRebootd is running but not iReboot and not the icon in the tray.
OK, that's just weird. Can you try copying a shortcut to iReboot to your startup folder and seeing if that does the trick? Or creating a task in the task scheduler to start iReboot at login?
Mahmoud - thanks for ideas - shall try this weekend. Do I need to worry about the sequence of irebootD.exe running first before I start iReboot.exe?
Mahmoud - Following your suggestions, the only thing that works is to add a task in task scheduler BUT ONLY after I set it both to "Run with highest privileges" and to "Delay task for: 1 minute". (I haven't tried 30 seconds.)

It starts at startup, not login.

By the way, the end result is that BOTH iReboot.exe and iRebootd.exe are running. Hope that's expected.

Yes, `iRebootd.exe` is the background service that actually performs the requested action with elevated rights, and `iReboot.exe` is the frontend that you see and interact with.
Mahmoud - thanks. I had previously tried "Run as Administrator" in the Properties for iReboot.exe and the shortcut .lnk, and those flags are still checked.
1) Should I uncheck them?
2) If I also find them checked in iRebootd.exe, should I uncheck them because your code already elevates?
3) Is anyone else having this issue? (I hardly ever use my Win 10, so I haven't done anything to it.)
I have noticed this behavior since the earliest days of Win10 beta, I think even back in the days of Win8. I beta test Windows so I dual-boot a lot. The problem here lies in the fact that the iReboot Service does not Start, even though it is set to Automatic. What happens is the program loads the tray icon when Win10 boots up, but the corresponding service does not start, that's why you will not get any right-click menu. The work-around for this is to open Services, find iReboot, then Start it. I hope the developers can find a way to fix this. It's very annoying. Once the service is started, you have right-menu functionality and use the program as intended. I know this thread is a month old, I was hoping by this time a newer version would have been released and have fixed this by now. Hoping somebody finds this post useful.
rcpax and gerryh - Mahmoud's suggestion worked for me. In Win 10, I put a task in task scheduler and it works BUT ONLY after I set it both to "Run with highest privileges" and to "Delay task for: 1 minute". (Haven't tried 30 seconds.)
Last edited by a moderator:
If iReboot 2 is not working on Windows 10, try running it in compatibility mode for an earlier Windows version. Right-click on the iReboot 2 executable, go to "Properties," navigate to the "Compatibility" tab, and select an older Windows version. If the issue persists, consider reaching out to the software's support or checking for updates on their official website.
This is from 2018 so I doubt anyone is still subscribed to this thread. iReboot 2.01.42 works fine in Windows 10 and Windows 11.

Thread locked.
Not open for further replies.